summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2021-03-13 20:57:54 -0500
committerDylan Delgado2021-03-13 20:57:54 -0500
commit04c74ea521422a2c2470cf0ac5e682dd806eb2ee (patch)
tree9c6ed24857fdba5d637e92ba982643d879a86d55
downloadaur-04c74ea521422a2c2470cf0ac5e682dd806eb2ee.tar.gz
Initial commit, based on version 0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12f1a90929b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-stack-data
+ pkgdesc = Python library that extracts data from stack frames and tracebacks
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/alexmojaki/stack_data
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pip
+ depends = python
+ source = git+https://github.com/alexmojaki/stack_data.git#tag=v0.1.0
+ sha256sums = SKIP
+
+pkgname = python-stack-data
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9a8abfafcb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#Maintainer: Dylan Delgado <dylan1496 at live dot com>
+
+_pkgname=stack_data
+pkgname=python-stack-data
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Python library that extracts data from stack frames and tracebacks"
+arch=('any')
+url="https://github.com/alexmojaki/stack_data"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools' 'python-pip')
+source=("git+https://github.com/alexmojaki/stack_data.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+} \ No newline at end of file