summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Vuillard2017-04-07 11:53:59 +0200
committerArthur Vuillard2017-04-07 11:53:59 +0200
commit6386363f44f7506c474f54e6b999c818011e967a (patch)
treeafdb676604a5dd84ab939e4fc016feb6c45f0498
downloadaur-6386363f44f7506c474f54e6b999c818011e967a.tar.gz
first package
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ca80f14ce06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-stagger
+ pkgdesc = ID3v1/ID3v2 tag manipulation package in pure Python 3
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://github.com/lorentey/stagger
+ arch = any
+ makedepends = python-setuptools
+ source = https://github.com/lorentey/stagger/archive/release-1.0.1.tar.gz
+ md5sums = b4b141bc36cfda0d6f9b2d40cff3b346
+
+pkgname = python-stagger
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87b64657ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70b7f5c21d33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=('python-stagger')
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="ID3v1/ID3v2 tag manipulation package in pure Python 3"
+arch=('any')
+url="http://github.com/lorentey/stagger"
+makedepends=('python-setuptools')
+source=("https://github.com/lorentey/stagger/archive/release-${pkgver}.tar.gz")
+md5sums=('b4b141bc36cfda0d6f9b2d40cff3b346')
+
+build() {
+ cd ${srcdir}/stagger-release-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/stagger-release-${pkgver}
+ python setup.py install --prefix=/usr --root=${pkgdir}
+}
+