summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-03 23:06:32 +0300
committerCaleb Maclennan2023-05-03 23:06:32 +0300
commit5faf61479b17c876b4fb6b31d37c17a83a39d85f (patch)
tree813f220d6aef1e419ec8efb5f47aa8b63259964c
parent6ef8889c9bff07918b979f2f4d3ea4603cc0daf6 (diff)
downloadaur-5faf61479b17c876b4fb6b31d37c17a83a39d85f.tar.gz
upgpkg: python-standardstreams 0.2.0-3
Rebuild for Python 3.11, normalize PEP517 build tooling
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6959e725bf9e..a59f0c38903e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-standardstreams
pkgdesc = Standard output, standard error, and standard input stream library
pkgver = 0.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/chrissimpkins/standardstreams
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
source = standardstreams-0.2.0.tar.gz::https://github.com/chrissimpkins/standardstreams/archive/v0.2.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 6eb40a25c242..d9ffdbbaa09b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
pkgname=python-standardstreams
pkgver=0.2.0
-pkgrel=2
+pkgrel=3
pkgdesc='Standard output, standard error, and standard input stream library'
arch=(any)
url="https://github.com/chrissimpkins/${pkgname#python-}"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="${pkgname#python-}-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('93d418bf48c3cad0bd158f5be0814fd17af60f74780e43f2e53976d2fb03425c')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}