summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-12-14 13:52:41 +0300
committerCaleb Maclennan2021-12-14 13:52:41 +0300
commit6ef8889c9bff07918b979f2f4d3ea4603cc0daf6 (patch)
treee872004e4a5da122e0748e4c82db5d09fef60e96
parentbc058104563841334e87c6f8b72fe1b3ab2a78ca (diff)
downloadaur-6ef8889c9bff07918b979f2f4d3ea4603cc0daf6.tar.gz
upgpkg: python-standardstreams 0.2.0-2
Rebuild for Python 3.10
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d9cdaaef5b8..6959e725bf9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-standardstreams
pkgdesc = Standard output, standard error, and standard input stream library
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/chrissimpkins/standardstreams
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = python-standardstreams-0.2.0.tar.gz::https://github.com/chrissimpkins/standardstreams/archive/v0.2.0.tar.gz
+ source = standardstreams-0.2.0.tar.gz::https://github.com/chrissimpkins/standardstreams/archive/v0.2.0.tar.gz
sha256sums = 93d418bf48c3cad0bd158f5be0814fd17af60f74780e43f2e53976d2fb03425c
pkgname = python-standardstreams
-
diff --git a/PKGBUILD b/PKGBUILD
index 764b85783292..6eb40a25c242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
pkgname=python-standardstreams
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Standard output, standard error, and standard input stream library'
arch=(any)
url="https://github.com/chrissimpkins/${pkgname#python-}"
-license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+license=(MIT)
+depends=(python)
+makedepends=(python-setuptools)
+_archive="${pkgname#python-}-$pkgver"
+source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('93d418bf48c3cad0bd158f5be0814fd17af60f74780e43f2e53976d2fb03425c')
build() {
- cd "${pkgname#python-}-$pkgver"
+ cd "$_archive"
python setup.py build
}
package() {
- cd "${pkgname#python-}-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}