summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax G2021-01-14 15:41:13 +0200
committerMax G2021-01-14 15:41:13 +0200
commit2c8513fde0c5c1c01c747ff14d50e1c203d79b41 (patch)
tree28f21894f44219a2f31e23508eb4f3ce8338bffa
downloadaur-2c8513fde0c5c1c01c747ff14d50e1c203d79b41.tar.gz
"Updated to v0.8.5"
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96c30388f33a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-stargen
+ pkgdesc = Framework for wordlist generation, combination and expansion
+ pkgver = 0.8.5
+ pkgrel = 1
+ url = https://github.com/codeswhite/stargen
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = crunch: Generating wordlists programmatically
+ source = https://files.pythonhosted.org/packages/source/s/stargen/stargen-0.8.5.tar.gz
+ sha256sums = c516546005510628638347870a972273c4297dfe38d0ddb83007281317061873
+
+pkgname = python-stargen
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24e603c8f48e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgbase='python-stargen'
+pkgname=('python-stargen')
+_module='stargen'
+pkgver=0.8.5
+pkgrel=1
+pkgdesc="Framework for wordlist generation, combination and expansion"
+url="https://github.com/codeswhite/stargen"
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('crunch: Generating wordlists programmatically')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=("c516546005510628638347870a972273c4297dfe38d0ddb83007281317061873")
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}