summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-05-08 18:55:32 -0500
committerLuis Martinez2022-05-08 18:55:32 -0500
commit77f3261e8a0e3bf5d96d1c88080cf3fd55f14864 (patch)
treebd2fec02a4577e9b475b98e4cd5fe317e26e00ca
parent5e185928d00987aea6cc34374a70b1b23c1d1d36 (diff)
downloadaur-77f3261e8a0e3bf5d96d1c88080cf3fd55f14864.tar.gz
package cleanup
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d580a5dba5a..8a0f35a18063 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-statprof
pkgdesc = Statistical profiling for Python
pkgver = 1.0.0
- pkgrel = 1
- url = http://pypi.python.org/pypi/statprof-smarkets/
+ pkgrel = 2
+ url = https://pypi.python.org/pypi/statprof-smarkets
arch = any
license = GPL2
- depends = python
- source = http://pypi.python.org/packages/source/s/statprof-smarkets/statprof-smarkets-1.0.0.tar.gz
- md5sums = 723d9c727da43a342042fe00486857d9
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-six
+ source = python-statprof-1.0.0.tar.gz::https://files.pythonhosted.org/packages/source/s/statprof-smarkets/statprof-smarkets-1.0.0.tar.gz
+ sha256sums = b1ecadfb86ead5c75d987fbc8cc0f53e1a3a6c6ea644918a67b3e8bb5036372f
pkgname = python-statprof
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f2b78b46ea4..38a9e04ecc41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
-# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Antony Lee <anntzer dot lee at gmail dot com>
pkgname=python-statprof
+_pkg="${pkgname#python-}-smarkets"
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Statistical profiling for Python'
arch=('any')
-url='http://pypi.python.org/pypi/statprof-smarkets/'
+url='https://pypi.python.org/pypi/statprof-smarkets'
license=('GPL2')
-depends=('python')
-source=("http://pypi.python.org/packages/source/s/statprof-smarkets/statprof-smarkets-$pkgver.tar.gz")
-md5sums=('723d9c727da43a342042fe00486857d9')
+depends=('python-six')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('b1ecadfb86ead5c75d987fbc8cc0f53e1a3a6c6ea644918a67b3e8bb5036372f')
-package() {
- cd "$srcdir/statprof-smarkets-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
+package() {
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+}