summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-12-03 00:29:44 +0800
committerlilac2020-12-03 00:29:44 +0800
commiteb0b3499589647654ad6bafc4b8414691bfb7fab (patch)
treed2b9b8782f6a7557b8fc28c021abf1dc41e5bf24
parent105231a2b196eb3af5c2284005e6638763931461 (diff)
downloadaur-eb0b3499589647654ad6bafc4b8414691bfb7fab.tar.gz
[lilac] updated to 3.3.0-4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66b63e10650d..5bdcc417a46b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-statsd
pkgdesc = A simple statsd client.
pkgver = 3.3.0
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/jsocol/pystatsd
arch = any
license = MIT
depends = python
depends = python-setuptools
source = https://files.pythonhosted.org/packages/source/s/statsd/statsd-3.3.0.tar.gz
- md5sums = b397ccf880f37cf099e775907ebf7a46
+ sha256sums = e3e6db4c246f7c59003e51c9720a51a7f39a396541cb9b147ff4b14d15b5dd1f
pkgname = python-statsd
diff --git a/PKGBUILD b/PKGBUILD
index 8c1c7202d968..bf4624d49774 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
-_pkgname=statsd
+_name=statsd
pkgname=python-statsd
pkgver=3.3.0
-pkgrel=2
+pkgrel=4
pkgdesc="A simple statsd client."
-arch=('any')
+arch=(any)
url="https://github.com/jsocol/pystatsd"
license=('MIT')
depends=('python' 'python-setuptools')
-_name=${pkgname#python-}
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('b397ccf880f37cf099e775907ebf7a46')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/statsd-3.3.0.tar.gz")
+sha256sums=('e3e6db4c246f7c59003e51c9720a51a7f39a396541cb9b147ff4b14d15b5dd1f')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py build
+ cd "$srcdir/statsd-3.3.0"
+ python3 setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/statsd-3.3.0"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+
+ # make sure we don't install any world-writable or root-readable-only files
+ # we shouldn't need to fix ownership as we extract tarballs as a non-root user
+ # https://github.com/pypa/setuptools/issues/1328
+ # https://github.com/LonamiWebs/Telethon/issues/1605
+ chmod u=rwX,go=rX -R "$pkgdir"
+ # make sure we don't install annoying files
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$_site_packages/tests/"
}
-# vim:set sw=2 et: