summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Schaf2016-01-30 21:36:34 +0100
committerPhil Schaf2016-01-30 21:36:34 +0100
commitc42dda1ba84c468ab3c2485803c4cc33dc94bbb3 (patch)
tree6660030c61e47cfd3458f5f80bd79429d228ac19
downloadaur-c42dda1ba84c468ab3c2485803c4cc33dc94bbb3.tar.gz
Initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ab0bb083262
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-stdeb
+ pkgdesc = Python to Debian source package conversion utility
+ pkgver = 0.8.5
+ pkgrel = 1
+ url = https://github.com/astraw/stdeb
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ depends = python-requests
+ depends = dpkg
+ source = https://pypi.python.org/packages/source/s/stdeb/stdeb-0.8.5.tar.gz
+ md5sums = afebfb9ca1c545fa15ad575679879f91
+
+pkgname = python-stdeb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a68bf221a49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+
+pkgname=python-stdeb
+pkgver=0.8.5
+pkgrel=1
+pkgdesc='Python to Debian source package conversion utility'
+arch=('any')
+url='https://github.com/astraw/stdeb'
+license=(' MIT')
+depends=('python' 'python-setuptools' 'python-requests' 'dpkg')
+source=("https://pypi.python.org/packages/source/s/stdeb/stdeb-$pkgver.tar.gz")
+md5sums=('afebfb9ca1c545fa15ad575679879f91')
+
+package() {
+ cd "$srcdir/stdeb-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}