summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-07-30 15:06:50 +0200
committerPhilipp A2020-07-30 15:06:50 +0200
commita92afafbf717e557affb46da0017609f16835ab7 (patch)
treedfda7a3952e296bb76e1af005ec5e0bd0238695b
downloadaur-a92afafbf717e557affb46da0017609f16835ab7.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94bd9bd2f5c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-stdlib-list
+ pkgdesc = A list of Python Standard Libraries (2.6-7, 3.2-8).
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/theislab/stdlib-list
+ arch = any
+ license = MIT
+ depends = python
+ noextract = stdlib_list-0.7.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/s/stdlib-list/stdlib_list-0.7.0-py3-none-any.whl
+ sha256sums = 0ed79a0badf4f666aad046cde364ccac68ca1438a211ec74b0153e0eb5642a3e
+
+pkgname = python-stdlib-list
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..910c2436b01b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.*
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fa1737c2770
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=stdlib-list
+pkgname=python-$_name
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='A list of Python Standard Libraries (2.6-7, 3.2-8).'
+arch=(any)
+url="https://github.com/theislab/$_name"
+license=(MIT)
+depends=(python)
+_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
+sha256sums=('0ed79a0badf4f666aad046cde364ccac68ca1438a211ec74b0153e0eb5642a3e')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}