summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-09-24 21:24:00 +0000
committerGeorge Rawlinson2021-09-24 21:24:00 +0000
commitdb938801f118e9ffeaf0fbfb010559335bd40e98 (patch)
tree02d2485471ed4fab8092ee38d610fdca09cb56a3
parent02a9342ff35f8e80c3fe8feadb3142170c6f1a7b (diff)
downloadaur-db938801f118e9ffeaf0fbfb010559335bd40e98.tar.gz
upgpkg: python-stdlib-list 0.8.0-1
* New upstream release. * Cleaned up PKGBUILD.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 37 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13eb9d93ecab..f8af9e63a386 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-stdlib-list
- pkgdesc = A list of Python Standard Libraries (2.6-7, 3.2-8).
- pkgver = 0.7.0
- pkgrel = 2
- url = https://github.com/jackmaney/stdlib-list
+ pkgdesc = A list of Python Standard Libraries
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/jackmaney/python-stdlib-list
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
- noextract = stdlib_list-0.7.0-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/s/stdlib-list/stdlib_list-0.7.0-py3-none-any.whl
- sha256sums = 0ed79a0badf4f666aad046cde364ccac68ca1438a211ec74b0153e0eb5642a3e
+ source = python-stdlib-list-0.8.0.tar.gz::https://github.com/jackmaney/python-stdlib-list/archive/v0.8.0.tar.gz
+ sha512sums = e18d893e257408125249064b9466e50f684a5358d0d8ab1693bf3529f23b47f82dc23b52cea6f8be89c7dc2bac58f8981ace0b7d7a016b295855562dba1aebc3
+ b2sums = 856b602fc7041fba987e9801571ecf9ccfafa935375dbc5a3248fd89803981b367fd03874b58a4f173bc6e5ed59e1d0711e54f2f210e640aeebc8c83eabce59d
pkgname = python-stdlib-list
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 910c2436b01b..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/src/
-/pkg/
-/*.pkg.*
-/*.whl
diff --git a/PKGBUILD b/PKGBUILD
index b71f98e21efd..1115b673d390 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
-# Maintainer: Philipp A. <flying-sheep@web.de>
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Contributor: Philipp A. <flying-sheep@web.de>
-_name=stdlib-list
-pkgname=python-$_name
-pkgver=0.7.0
-pkgrel=2
-pkgdesc='A list of Python Standard Libraries (2.6-7, 3.2-8).'
-arch=(any)
-url="https://github.com/jackmaney/$_name"
-license=(MIT)
-depends=(python)
-_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
-sha256sums=('0ed79a0badf4f666aad046cde364ccac68ca1438a211ec74b0153e0eb5642a3e')
-noextract=("$_wheel")
+pkgname=python-stdlib-list
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="A list of Python Standard Libraries"
+arch=('any')
+url="https://github.com/jackmaney/python-stdlib-list"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('e18d893e257408125249064b9466e50f684a5358d0d8ab1693bf3529f23b47f82dc23b52cea6f8be89c7dc2bac58f8981ace0b7d7a016b295855562dba1aebc3')
+b2sums=('856b602fc7041fba987e9801571ecf9ccfafa935375dbc5a3248fd89803981b367fd03874b58a4f173bc6e5ed59e1d0711e54f2f210e640aeebc8c83eabce59d')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py build
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
+ cd "$pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ # documentation
+ install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+
+ # license
+ install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}