summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaylor Smock2015-11-15 06:52:42 -0700
committerTaylor Smock2015-11-15 06:52:42 -0700
commit26004daf1a1fe0b53046b3dc53a63d9e4edce0a7 (patch)
treef27f18a83f759a6057c257288d2eaf9455430d62
downloadaur-26004daf1a1fe0b53046b3dc53a63d9e4edce0a7.tar.gz
Initial commit
* Conflicts with steamcontroller-udev because the recommended udev configuration is slightly different. * Install script calls udevadm control --reload * changelog has basic info
-rw-r--r--.SRCINFO25
-rw-r--r--99-steamcontroller.rules5
-rw-r--r--PKGBUILD42
-rw-r--r--changelog.txt49
-rw-r--r--steamcontroller.install17
5 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdb12baefeb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-steamcontroller-git
+ pkgdesc = Standalone userland driver for the Steam controller
+ pkgver = 6ab9f2a
+ pkgrel = 1
+ url = https://github.com/ynsta/steamcontroller
+ install = steamcontroller.install
+ changelog = changelog.txt
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python-distutils-extra
+ depends = python-libusb1
+ optdepends = steamcontroller-udev: Required to have the controller recognized
+ optdepends = python-pyside
+ optdepends = python-pyqtgraph
+ provides = steamcontroller
+ conflicts = steamcontroller
+ conflicts = steamcontroller-udev
+ source = git+https://github.com/ynsta/steamcontroller.git
+ source = 99-steamcontroller.rules
+ sha256sums = SKIP
+ sha256sums = 46de34b75730482e5276d94f072dd1911c48789f4442a41c56653b2db05ef46d
+
+pkgname = python-steamcontroller-git
+
diff --git a/99-steamcontroller.rules b/99-steamcontroller.rules
new file mode 100644
index 000000000000..5e91ccd8025b
--- /dev/null
+++ b/99-steamcontroller.rules
@@ -0,0 +1,5 @@
+# Steam controller keyboard/mouse mode
+SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", GROUP="games", MODE="0660"
+
+# Steam controller gamepad mode
+KERNEL=="uinput", MODE="0660", GROUP="games", OPTIONS+="static_node=uinput"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1726f2ee1000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: vorpalblade77@gmail.com
+pkgname=python-steamcontroller-git
+_pkgname=steamcontroller
+pkgver=6ab9f2a
+pkgrel=1
+pkgdesc="Standalone userland driver for the Steam controller"
+arch=('i686' 'x86_64')
+url="https://github.com/ynsta/${_pkgname}"
+license=('MIT')
+makedepends=('python-distutils-extra')
+depends=('python-libusb1')
+optdepends=('steamcontroller-udev: Required to have the controller recognized'
+ 'python-pyside'
+ 'python-pyqtgraph')
+provides=('steamcontroller')
+conflicts=("${_pkgname}" 'steamcontroller-udev')
+changelog=('changelog.txt')
+source=("git+https://github.com/ynsta/${_pkgname}.git"
+ "99-steamcontroller.rules")
+sha256sums=('SKIP'
+ '46de34b75730482e5276d94f072dd1911c48789f4442a41c56653b2db05ef46d')
+install='steamcontroller.install'
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --always | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ install -m755 -d "${pkgdir}/usr/lib/udev/rules.d"
+ install -Dm 644 "99-steamcontroller.rules" "${pkgdir}/usr/lib/udev/rules.d/99-steamcontroller.rules"
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}" \
+ --prefix="/usr" \
+ --compile -O1
+ install -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/changelog.txt b/changelog.txt
new file mode 100644
index 000000000000..7e9c39f92fd4
--- /dev/null
+++ b/changelog.txt
@@ -0,0 +1,49 @@
+Initial code
+ * Not really working
+ * Try "echo 8f07005e 015e01f4 01000000 | sc-test-cmsg.py" to check
+ * sc-xbox.py start *should* start emulating the 360 controller.Initial
+ code
+ * Not really working
+ * Try "echo 8f07005e 015e01f4 01000000 | sc-test-cmsg.py" to
+ check
+ * sc-xbox.py start *should* start emulating the 360
+ controller.Initial code
+ * Not really working
+ * Try "echo 8f07005e 015e01f4 01000000 |
+ sc-test-cmsg.py" to check
+ * sc-xbox.py start *should* start emulating the 360
+ controller.Initial code
+ * Not really working
+ * Try "echo 8f07005e 015e01f4 01000000 |
+ sc-test-cmsg.py" to check
+ * sc-xbox.py start *should* start emulating
+ the 360 controller.Initial code
+ * Not really working
+ * Try "echo 8f07005e 015e01f4 01000000
+ | sc-test-cmsg.py" to check
+ * sc-xbox.py start *should* start
+ emulating the 360 controller.Initial
+ code
+ * Not really working
+ * Try "echo 8f07005e 015e01f4
+ 01000000 | sc-test-cmsg.py" to
+ check
+ * sc-xbox.py start *should*
+ start emulating the 360
+ controller.Initial code
+ * Not really working
+
+ * Try "echo 8f07005e 015e01f4
+ 01000000 | sc-test-cmsg.py" to
+ check
+ * sc-xbox.py start *should*
+ start emulating the 360
+ controller.Initial code
+ * Not really working
+
+ * Try "echo 8f07005e 015e01f4
+ 01000000 | sc-test-cmsg.py" to
+ check
+ * sc-xbox.py start *should*
+ start emulating the 360
+ controller.
diff --git a/steamcontroller.install b/steamcontroller.install
new file mode 100644
index 000000000000..ccf121a71a89
--- /dev/null
+++ b/steamcontroller.install
@@ -0,0 +1,17 @@
+__GROUP="games"
+post_install() {
+ getent group ${__GROUP} >> /dev/null || /usr/sbin/groupadd ${__GROUP} || return 1
+ /bin/cat <<EOF
+==> Please add all users that will be running Steam to the "${__GROUP}" group
+EOF
+ udevadm control --reload
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ getent group $__{GROUP} &>/dev/null && /usr/sbin/groupdel ${__GROUP}
+}
+