summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaylor Smock2016-12-01 15:38:29 -0700
committerTaylor Smock2016-12-01 15:38:29 -0700
commita0baa0a3a4c3cfcb5a5ac12ea131740f1a0063d2 (patch)
treeb926e77693caa49b7e291fc0b3ced444890eb1b0
parent6078ab013d149465c924056f0310bee065788f66 (diff)
downloadaur-a0baa0a3a4c3cfcb5a5ac12ea131740f1a0063d2.tar.gz
PKGBUILD: Update pkgver to comply with newer aur standards
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beb6ac3ff79a..ebafaaad292d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Sep 30 11:22:33 UTC 2016
+# Thu Dec 1 22:38:08 UTC 2016
pkgbase = python-steamcontroller-git
pkgdesc = Standalone userland driver for the Steam controller
- pkgver = 02f27c4
+ pkgver = r104.fe66e53
pkgrel = 1
url = https://github.com/ynsta/steamcontroller
install = steamcontroller.install
diff --git a/PKGBUILD b/PKGBUILD
index f75fb036926f..b5500f5be20c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: vorpalblade77@gmail.com
pkgname=python-steamcontroller-git
_pkgname=steamcontroller
-pkgver=02f27c4
+pkgver=r104.fe66e53
pkgrel=1
pkgdesc="Standalone userland driver for the Steam controller"
arch=('i686' 'x86_64')
@@ -21,7 +21,11 @@ install='steamcontroller.install'
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --always | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+# git describe --always | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {