summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2017-04-24 07:27:49 -0400
committerbrent s2017-04-24 07:27:49 -0400
commit5db15b6d50f47628136442560cd3d7cb3b29175e (patch)
treec1aa9b5be79cab1f06c8fa3944906c48f51aaaa3
parent04d902803381d34c2285d33b279926afbf25b379 (diff)
downloadaur-5db15b6d50f47628136442560cd3d7cb3b29175e.tar.gz
updating build
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cfc285d2f48..9cab8659ac18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
-# Generated by aurpkgs
-# Mon Apr 24 11:22:13 UTC 2017
+# Generated by mksrcinfo v8
+# Mon Apr 24 11:27:49 UTC 2017
pkgbase = python-steamodd-git
pkgdesc = Python module for working with Steam's API
- pkgver = False
+ pkgver = v4.21.r1.g530f5d1
pkgrel = 1
url = https://steamodd.readthedocs.io/en/latest/
arch = i686
arch = x86_64
license = CUSTOM
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
source = python-steamodd::git+https://github.com/Lagg/steamodd.git
sha512sums = SKIP
- sha512sums = SKIP
pkgname = python-steamodd-git
+
diff --git a/PKGBUILD b/PKGBUILD
index cf6fb6c1aa1e..1d9b0d0a309c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=python-steamodd-git
-pkgver=0.0001
+pkgver=v4.21.r1.g530f5d1
pkgrel=1
pkgdesc="Python module for working with Steam's API"
arch=( 'i686' 'x86_64' )
url="https://steamodd.readthedocs.io/en/latest/"
license=( 'CUSTOM' )
makedepends=( 'python' 'python-setuptools' 'python2' 'python2-setuptools' )
-_pkgname=python-steamodd
+_pkgname=steamodd
install=
changelog=
noextract=()
@@ -18,11 +18,11 @@ source=("python-steamodd::git+https://github.com/Lagg/steamodd.git")
# see https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_Submodules if you require git submodules
sha512sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/python-${_pkgname}"
# no tags, so number of revisions e.g. r1142.a17a017
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
## most recent annotated tag e.g. 2.0.r6.ga17a017
- #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
## most recent un-annotated tag e.g. 0.71.r115.gd95ee07
#git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
## or:
@@ -35,11 +35,17 @@ pkgver() {
# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
#)
}
-build() {
- cd "${srcdir}/${_pkgname}/src"
- make prefix=${pkgdir}/usr
+
+package_python-steamodd() {
+ depends=('python')
+ cd "${srcdir}/python-${_pkgname}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package() {
- install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
- install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+
+package_python2-steamodd() {
+ depends=('python')
+ cd "${srcdir}/python-${_pkgname}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}