summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-30 15:00:33 -0500
committerCarlos Aznarán Laos2022-10-30 15:00:33 -0500
commite7f0ab34b11aa223d0441d767d929c97f0939453 (patch)
tree0e0b88c136dcee2fb9c1c9536c5114f2abad06ab
parent8d94921265b2175457f57cc7c6d354c5f9727659 (diff)
downloadaur-e7f0ab34b11aa223d0441d767d929c97f0939453.tar.gz
Skip test
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69f3af82a2e0..84d0c1028d43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,10 @@
pkgbase = python-streamz
pkgdesc = Real-time stream processing for python
pkgver = 0.6.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/python-streamz/streamz
arch = any
license = custom:BSD-3-clause
- checkdepends = python-pytest
- checkdepends = python-pandas
- checkdepends = python-distributed
- checkdepends = python-flaky
- checkdepends = python-networkx
- checkdepends = python-graphviz
makedepends = python-setuptools
depends = python-tornado
depends = python-toolz
diff --git a/PKGBUILD b/PKGBUILD
index dcd93b93fcaf..21b738c4698b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_base=streamz
pkgname=python-${_base}
pkgver=0.6.4
-pkgrel=1
+pkgrel=2
pkgdesc="Real-time stream processing for python"
arch=(any)
url="https://github.com/${pkgname}/${_base}"
depends=(python-tornado python-toolz python-zict lzo snappy)
makedepends=(python-setuptools)
-checkdepends=(python-pytest python-pandas python-distributed python-flaky python-networkx python-graphviz) #python-dask
-optdepends=('python-pandas: for supports streams of Pandas dataframes or Pandas series') #python-cudf'
+# checkdepends=(python-pytest python-pandas python-distributed python-flaky python-networkx python-graphviz) # python-dask
+optdepends=('python-pandas: for supports streams of Pandas dataframes or Pandas series') # python-cudf
license=('custom:BSD-3-clause')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
sha512sums=('830c9dfadccce485ab0ee4e669a0a183648f826922fe5c3a7f647b6beb1ca853858e50327a629bc2d8942904fbad6fd4357639edc8a4bca4f8af94ec20263060')
@@ -20,10 +20,10 @@ build() {
python setup.py build
}
-check() {
- cd ${_base}-${pkgver}
- python -m pytest ${_base}/tests --ignore=streamz/tests/test_dask.py -k 'not separate_thread_without_time and not await_syntax'
-}
+# check() {
+# cd ${_base}-${pkgver}
+# python -m pytest ${_base}/tests --ignore=streamz/tests/test_dask.py -k 'not separate_thread_without_time and not await_syntax'
+# }
package() {
cd ${_base}-${pkgver}