summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacomo Longo2018-08-26 00:16:13 +0200
committerGiacomo Longo2018-08-26 00:16:13 +0200
commit1cf94c0c1006cc390897b0c9b036fb3108000961 (patch)
tree149e15331d2179cf4235b12d101e262dde6748ae
downloadaur-1cf94c0c1006cc390897b0c9b036fb3108000961.tar.gz
python-string-utils - Version 0.6.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..855bce065fcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-string-utils
+ pkgdesc = Utility functions for strings checking and manipulation
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/openshift/openshift-restclient-python
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/python-string-utils/python-string-utils-0.6.0.tar.gz
+ md5sums = 76ae6911f4bf0f1e76cd9be749c16745
+
+pkgname = python-string-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70994af0f556
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Giacomo Longo <gabibbo97@gmail.com>
+pkgname=python-string-utils
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Utility functions for strings checking and manipulation"
+url="https://github.com/openshift/openshift-restclient-python"
+license=('APACHE')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+arch=('any')
+makedepends=('python-setuptools')
+depends=('python')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+md5sums=('76ae6911f4bf0f1e76cd9be749c16745')