summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-30 13:14:35 -0500
committerCarlos Aznarán Laos2022-08-30 13:14:35 -0500
commitf9cf834ed7a241f2cd38bc3e65b32d563831715a (patch)
treea11b39dcdc8a2157bda7f7a8463f8dd9c4214db2
parentcec3539b023e509b89689746d7a642a23dd4f4a7 (diff)
downloadaur-f9cf834ed7a241f2cd38bc3e65b32d563831715a.tar.gz
Bump version to 1.0b3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 254d3fb7b359..ca6ac7c21fb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-stringly
pkgdesc = Stringly typed command line interface
- pkgver = 1.0b2
+ pkgver = 1.0b3
pkgrel = 1
url = https://github.com/evalf/stringly
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-flit-core
+ makedepends = python-install
depends = python-typing_extensions
- source = https://github.com/evalf/stringly/archive/v1.0b2.tar.gz
- sha512sums = a647b98e5131b77b00520a92e58699f996ed13ec25e5fafdbd582e6f2e9ab57399be744f46e097e18c9043dd49b71bebc7c54f72a062144065254aacccb53945
+ source = https://pypi.org/packages/source/s/stringly/stringly-1.0b3.tar.gz
+ sha512sums = e7268f21fea6dc3ab4320e210dc0e38e084b7a645e37de6b51250c865f15b4a495f90df50d4acbbf9a8d7e4bd4d1dbc543e9c033c151e4ab16d972c092875426
pkgname = python-stringly
diff --git a/PKGBUILD b/PKGBUILD
index 73e330d9bc53..b4d508c87e0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,35 @@
_base=stringly
pkgname=python-${_base}
pkgdesc="Stringly typed command line interface"
-pkgver=1.0b2
+pkgver=1.0b3
pkgrel=1
arch=(any)
url="https://github.com/evalf/${_base}"
license=(MIT)
depends=(python-typing_extensions)
-makedepends=(python-setuptools)
-source=(${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('a647b98e5131b77b00520a92e58699f996ed13ec25e5fafdbd582e6f2e9ab57399be744f46e097e18c9043dd49b71bebc7c54f72a062144065254aacccb53945')
+makedepends=(python-build python-flit-core python-install)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('e7268f21fea6dc3ab4320e210dc0e38e084b7a645e37de6b51250c865f15b4a495f90df50d4acbbf9a8d7e4bd4d1dbc543e9c033c151e4ab16d972c092875426')
build() {
cd ${_base}-${pkgver}
- export PYTHONHASHSEED=0
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
cd ${_base}-${pkgver}
- python setup.py test
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m install --optimize=1 dist/*.whl
+ test-env/bin/python -m unittest
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}