summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-28 22:47:49 +0800
committerUniversebenzene2019-08-28 22:47:49 +0800
commitfd04d4309bacdac121d825cedaa4dae62449ecdd (patch)
treece95abf4c5fe424c102ba8d1b0c837ca10230461
downloadaur-fd04d4309bacdac121d825cedaa4dae62449ecdd.tar.gz
Initial import 2.3.3
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
-rw-r--r--fix_new_sphinx.patch11
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73c7bcb85f95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-stsci.image-doc
+ pkgdesc = Documentation for STScI Image
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = https://github.com/spacetelescope/stsci.image
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2-stsci.image=2.3.3
+ makedepends = python2-numpydoc
+ makedepends = python2-stsci.sphinxext
+ makedepends = python2-matplotlib
+ source = https://github.com/spacetelescope/stsci.image/archive/2.3.3.tar.gz
+ source = fix_new_sphinx.patch
+ md5sums = 3067df5c19b14573b17c080931acc93c
+ md5sums = 561121bb3958143ce70f2f8ba1971747
+
+pkgname = python-stsci.image-doc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1df7b618a7b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae760abff07d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=stsci.image
+pkgname=python-${_pyname}-doc
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="Documentation for STScI Image"
+arch=('i686' 'x86_64')
+url="https://github.com/spacetelescope/stsci.image"
+license=('BSD')
+makedepends=("python2-${_pyname}=${pkgver}" 'python2-numpydoc' 'python2-stsci.sphinxext' 'python2-matplotlib')
+source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz"
+ 'fix_new_sphinx.patch')
+md5sums=('3067df5c19b14573b17c080931acc93c'
+ '561121bb3958143ce70f2f8ba1971747')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/fix_new_sphinx.patch"
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ make SPHINXBUILD=sphinx-build2 html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}
diff --git a/fix_new_sphinx.patch b/fix_new_sphinx.patch
new file mode 100644
index 000000000000..e3614818cac9
--- /dev/null
+++ b/fix_new_sphinx.patch
@@ -0,0 +1,11 @@
+--- a/docs/source/conf.py 2019-08-21 23:41:49.000000000 +0800
++++ b/docs/source/conf.py 2019-08-28 22:01:40.031964404 +0800
+@@ -24,7 +24,7 @@
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+ extensions += ['sphinx.ext.autodoc', 'sphinx.ext.doctest',
+- 'sphinx.ext.intersphinx', 'sphinx.ext.pngmath']
++ 'sphinx.ext.intersphinx', 'sphinx.ext.imgmath']
+
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']