summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-29 13:27:59 +0800
committerUniversebenzene2019-08-29 13:27:59 +0800
commit627b23c53d7e38ff34701f1302a01dfda0605f65 (patch)
tree4b5485258270b6f57211d2be667efc81d23f97b6
downloadaur-627b23c53d7e38ff34701f1302a01dfda0605f65.tar.gz
Initial import 1.5.1
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD35
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f894d6fc53b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-stwcs
+ pkgdesc = WCS based distortion models and coordinate transformation
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://stwcs.readthedocs.io/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python-relic
+ source = https://files.pythonhosted.org/packages/source/s/stwcs/stwcs-1.5.1.tar.gz
+ md5sums = b605e2c557f1fffee05a6db53e198b3a
+
+pkgname = python-stwcs
+ depends = python>=3.5
+ depends = python-stsci.tools>=3.5.2
+ depends = python-requests
+ depends = python-lxml
+ optdepends = python-stwcs-doc: Documentation for STWCS
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef6375f75615
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+LICENSE*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..317edbfcc991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgbase=python-stwcs
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="WCS based distortion models and coordinate transformation"
+arch=('i686' 'x86_64')
+url="https://stwcs.readthedocs.io/"
+license=('BSD')
+makedepends=('python-setuptools' 'python-relic')
+#checkdepends=('python-pytest' 'python-stsci.tools' 'python-lxml')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('b605e2c557f1fffee05a6db53e198b3a')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
+}
+
+#check() {
+# cd ${srcdir}/${_pyname}-${pkgver}
+#
+# python setup.py test
+#}
+
+package_python-stwcs() {
+ depends=('python>=3.5' 'python-stsci.tools>=3.5.2' 'python-requests' 'python-lxml')
+ optdepends=('python-stwcs-doc: Documentation for STWCS')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}