summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel2016-10-11 12:22:33 +0200
committerGabriel2016-10-11 12:22:33 +0200
commitb2b36ff6b271bc9ce5c353dcfba3a0ed85216ffc (patch)
tree07b511d9f0274ee4a4c6f9370f8e3ec6ab6c38d5
downloadaur-b2b36ff6b271bc9ce5c353dcfba3a0ed85216ffc.tar.gz
create package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1c19d2b0292
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-sunpy-git
+ pkgdesc = Python library for solar physics
+ pkgver = 0.8.dev
+ pkgrel = 1
+ url = http://www.sunpy.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python-astropy
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = python-suds
+ depends = python-pandas
+ depends = python-beautifulsoup4
+ depends = python-sqlalchemy
+ provides = python-sunpy
+ conflicts = python-sunpy
+ options = !emptydirs
+ source = git+https://github.com/sunpy/sunpy
+ md5sums = SKIP
+
+pkgname = python-sunpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d5af6fe3679
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gabriel "ArcturusB" Perouze" <arcturus@openmailbox.org>
+
+pkgname=python-sunpy-git
+_gitname=sunpy
+pkgver=0.8.dev
+pkgrel=1
+pkgdesc="Python library for solar physics"
+arch=('i686' 'x86_64')
+url="http://www.sunpy.org/"
+license=('BSD')
+depends=('python'
+ 'python-astropy'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-matplotlib'
+ 'python-suds'
+ 'python-pandas'
+ 'python-beautifulsoup4'
+ 'python-sqlalchemy')
+makedepends=('git')
+provides=(python-sunpy)
+conflicts=(python-sunpy)
+options=(!emptydirs)
+install=
+source=(git+https://github.com/sunpy/sunpy)
+md5sums=('SKIP')
+_gitname=sunpy
+
+pkgver() {
+ cd "${_gitname}"
+ # printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s%s.%s" "$(grep "VERSION = " setup.py | cut -d\' -f2)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_gitname}"
+ python setup.py install --root="${pkgdir}"
+}
+
+# vim:set ts=2 sw=2 et: