summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-05-08 17:33:11 +0800
committerUniversebenzene2022-05-08 17:33:11 +0800
commitf1ade99887ae333a3e572694a26a9398427df12e (patch)
treee5bd65649e651a2854a75eb7d6cbd0a37f28970c
parent30d6b144216b925ba2b0b4fa2657569eea002b43 (diff)
downloadaur-f1ade99887ae333a3e572694a26a9398427df12e.tar.gz
Update to version 1.2.30
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--setup.py22
3 files changed, 48 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c1f23a1572d..a0f1b9ca1549 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-sunpy-sphinx-theme
pkgdesc = The sphinx theme for the SunPy website and documentation
- pkgver = 1.2.29
+ pkgver = 1.2.30
pkgrel = 1
url = https://github.com/sunpy/sunpy-sphinx-theme
arch = any
license = BSD
+ checkdepends = python-nose
+ checkdepends = python-sunpy
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- source = https://files.pythonhosted.org/packages/source/s/sunpy-sphinx-theme/sunpy-sphinx-theme-1.2.29.tar.gz
- md5sums = f4bb546e9206c770524c8c2a5661e682
+ source = https://files.pythonhosted.org/packages/source/s/sunpy-sphinx-theme/sunpy-sphinx-theme-1.2.30.tar.gz
+ source = setup.py
+ md5sums = 97931ecefb1dc5f7c645e48516abd0f0
+ md5sums = 8bbd0e92c81e8eb3b0a9ba9977198c8d
pkgname = python-sunpy-sphinx-theme
depends = python-sphinx
diff --git a/PKGBUILD b/PKGBUILD
index f3593702bd96..5da9782150e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-sunpy-sphinx-theme
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.2.29
+pkgver=1.2.30
pkgrel=1
pkgdesc="The sphinx theme for the SunPy website and documentation"
arch=('any')
@@ -10,8 +10,17 @@ url="https://github.com/sunpy/sunpy-sphinx-theme"
license=('BSD')
makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
#checkdepends=('python-pytest' 'python-sphinx' 'python-sphinx-bootstrap-theme')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('f4bb546e9206c770524c8c2a5661e682')
+checkdepends=('python-nose' 'python-sunpy')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'setup.py')
+md5sums=('97931ecefb1dc5f7c645e48516abd0f0'
+ '8bbd0e92c81e8eb3b0a9ba9977198c8d')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ ln -rs ${srcdir}/setup.py .
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -19,12 +28,13 @@ build() {
python -m build --wheel --no-isolation
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# python setup.py test
-## pytest
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+# python setup.py test
+# pytest
+ nosetests
+}
package_python-sunpy-sphinx-theme() {
depends=('python-sphinx' 'python-sphinx-bootstrap-theme')
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..24548eedd0da
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+from setuptools import setup
+
+setup(
+ name="sunpy-sphinx-theme",
+ use_scm_version=True,
+ setup_requires=["setuptools_scm"],
+ use_2to3=False,
+ description="The sphinx theme for the SunPy website and documentation.",
+ long_description="The sphinx theme for the SunPy website and documentation.",
+ author="The SunPy Developers",
+ install_requires=["sphinx-bootstrap-theme"],
+ packages=["sunpy_sphinx_theme"],
+ include_package_data=True,
+ license="2-clause BSD",
+ classifiers=[
+ "Intended Audience :: Developers",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Operating System :: OS Independent",
+ "License :: OSI Approved :: BSD License",
+ ],
+)