summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu, Zhenyu2024-04-09 16:15:34 +0800
committerWu, Zhenyu2024-04-09 16:15:34 +0800
commit5f1fd1cd7711d3f6e9176e40a856013b3e3a27f3 (patch)
treeffc3f1798a86044e687e2ad37184af84044439d3
downloadaur-5f1fd1cd7711d3f6e9176e40a856013b3e3a27f3.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1d6794ffb63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-super-mario
+ pkgdesc = a improved supermario game
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/marblexu/PythonPlantsVsZombies
+ arch = any
+ license = MIT
+ makedepends = python-installer
+ depends = python-pygame
+ source = https://files.pythonhosted.org/packages/py3/s/super_mario/super_mario_game-0.0.1-py3-none-any.whl
+ sha256sums = b85da52d7bf06dda1eb8fd35d951bf1576e2bdd94bb2f6442e776a3f66373b0c
+
+pkgname = python-super-mario
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b62e7679d6f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
+!/nvchecker.toml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..484aa2957ade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+_pkgname=super-mario
+pkgname=python-$_pkgname
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="a improved supermario game"
+arch=(any)
+url=https://github.com/marblexu/PythonPlantsVsZombies
+depends=(python-pygame)
+makedepends=(python-installer)
+license=(MIT)
+_py=py3
+source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/${_pkgname//-/_}/${_pkgname//-/_}_game-$pkgver-$_py-none-any.whl")
+sha256sums=('b85da52d7bf06dda1eb8fd35d951bf1576e2bdd94bb2f6442e776a3f66373b0c')
+
+package() {
+ python -minstaller -d"$pkgdir" ./*.whl
+}