summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandr Petrosyan2024-01-03 17:52:45 +0400
committerAleksandr Petrosyan2024-01-03 17:52:45 +0400
commit7aafa39bb75230007a68ca7b07b35d0260242ae2 (patch)
tree54bddd6c1bb9a73014fe8b75a9e521bef1dd7953
downloadaur-7aafa39bb75230007a68ca7b07b35d0260242ae2.tar.gz
[init]: initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a77f9a08fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-supernest
+ pkgdesc = A wrapper for usage of suerpositional nested sampling and repartitioning in the wild
+ pkgver = 3.4.0
+ pkgrel = 1
+ url = https://gitlab.com/a-p-petrosyan/sspr
+ arch = any
+ license = LGPL
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-mpi4py
+ depends = python-polychord
+ optdepends = openblas: faster linear algebra
+ provides = anesthetic
+ options = !emptydirs
+ source = https://gitlab.com/appetrosyan/sspr/-/archive/3.4.0/sspr-3.4.0.tar.gz
+ sha256sums = 4e3970751f64c54ecee7b47f1883db0494c7d82cd6e717dcf397f74e15da74fb
+
+pkgname = python-supernest
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5802de640f58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aleksandr Petrosyan <ap886@cantab.ac.uk> (aur.archlinux.org/account/appetrosyan)
+pkgname=python-supernest
+_name=sspr
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="A wrapper for usage of suerpositional nested sampling and repartitioning in the wild"
+arch=(any)
+url="https://gitlab.com/a-p-petrosyan/sspr"
+license=(LGPL)
+groups=()
+depends=(python-numpy python-matplotlib python-scipy python-pandas python-mpi4py python-polychord)
+optdepends=('openblas: faster linear algebra')
+makedepends=(python-build python-installer)
+provides=(anesthetic)
+options=(!emptydirs)
+install=
+source=("https://gitlab.com/appetrosyan/${_name}/-/archive/${pkgver}/${_name}-${pkgver}.tar.gz")
+sha256sums=('4e3970751f64c54ecee7b47f1883db0494c7d82cd6e717dcf397f74e15da74fb')
+
+build() {
+ cd "$srcdir/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}
+