summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScheiermann2021-01-28 11:23:20 +0100
committerScheiermann2021-01-28 11:23:20 +0100
commit28d756a7342825411ee7ac099e8136c0d939712a (patch)
tree33fe11ee80b8cada7d5026284f1fbc66c7f0920b
parent1b0e8bde6686cea28e230e13f3a50a431d809c71 (diff)
downloadaur-28d756a7342825411ee7ac099e8136c0d939712a.tar.gz
Release 0.1.25
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65e06d11141d..3d367dc623f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-supersolids
pkgdesc = Notes and script to supersolids
- pkgver = 0.1.24
+ pkgver = 0.1.25
pkgrel = 1
url = https://github.com/Scheiermann/supersolids
arch = any
@@ -10,14 +10,12 @@ pkgbase = python-supersolids
depends = python-ffmpeg
depends = python-matplotlib
depends = python-numpy
- depends = python-pyqt5
depends = python-sphinx-autoapi
depends = python-sphinx_rtd_theme
depends = python-scipy
- depends = vtk
depends = mayavi
optdepends =
- source = supersolids-0.1.24.tar.gz::https://files.pythonhosted.org/packages/source/s/supersolids/supersolids-0.1.24.tar.gz
+ source = supersolids-0.1.25.tar.gz::https://files.pythonhosted.org/packages/source/s/supersolids/supersolids-0.1.25.tar.gz
sha256sums = SKIP
pkgname = python-supersolids
diff --git a/PKGBUILD b/PKGBUILD
index 2567ec339b3c..a5a4dadb6df9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
# Maintainer: Daniel Scheiermann <daniel.scheiermann@stud.uni-hannover.de>
_name=supersolids
pkgname=python-${_name}
-pkgver=0.1.24
+pkgver=0.1.25
pkgrel=1
pkgdesc="Notes and script to supersolids"
url="https://github.com/Scheiermann/${_name}"
arch=(any)
license=("MIT")
-depends=("ffmpeg" "python-ffmpeg"
- "python-matplotlib" "python-numpy" "python-pyqt5"
+depends=("ffmpeg" "python-ffmpeg" "python-matplotlib" "python-numpy"
"python-sphinx-autoapi" "python-sphinx_rtd_theme" "python-scipy"
- "vtk"
"mayavi"
)
makedepends=("python-setuptools")
@@ -32,11 +30,11 @@ package() {
cd "$srcdir/${_name}-$pkgver"
# alternatively install dependencies with pip
# for python3.8
- # python -m pip install -U autoapi apptools envisage ffmpeg-python mayavi matplotlib numpy scipy sphinx-rtd-theme traits traitsui vtk
- # for python3.9
+ # python -m pip install -U autoapi ffmpeg-python numpy matplotlib mayavi psutil scipy sphinx-rtd-theme
+ # for python3.9 (to install mayavi, vtk is needed)
# (watch out: currently there is no vtk wheel for python3.9, so you need to build it from source
- # or take a unofficial build (provided by the project creator of this package), then install mayavi)
- # python -m pip install -U autoapi apptools envisage ffmpeg-python matplotlib numpy scipy sphinx-rtd-theme traits traitsui vtk
+ # or take an unofficial build (provided by the project creator of this package), then install mayavi)
+ # python -m pip install -U autoapi ffmpeg-python numpy matplotlib mayavi psutil scipy sphinx-rtd-theme
python setup.py install --skip-build --root="$pkgdir" --optimize=1
}