summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoxackie2020-12-06 09:12:19 +0000
committercoxackie2020-12-06 09:12:19 +0000
commit80d08f9b106fbe933c79b00d2d1d205c2d8559ac (patch)
treefc600eb6bbcf46fb3f9f5465c7c84e053dc76bc5
downloadaur-80d08f9b106fbe933c79b00d2d1d205c2d8559ac.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32ad23b6f157
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-survey
+ pkgdesc = A simple library for creating beautiful interactive prompts.
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/Exahilosys/survey
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python>=3.5
+ depends = python-wrapio
+ provides = python-survey
+ source = https://github.com/Exahilosys/survey/archive/v2.2.1.tar.gz
+ md5sums = 7c42870b4f428de6b73948286ab30db7
+
+pkgname = python-survey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e41e2a3ec48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Kostas Kardaras <firstname dot lastname at gmail>
+
+_pkgname='survey'
+pkgname='python-survey'
+provides=('python-survey')
+conflicts=()
+pkgver=2.2.1
+pkgrel=1
+pkgdesc='A simple library for creating beautiful interactive prompts.'
+arch=('x86_64')
+url="https://github.com/Exahilosys/${_pkgname}"
+license=('MIT')
+source=("${url}/archive/v${pkgver}.tar.gz")
+makedepends=('python-setuptools')
+depends=(
+ 'python>=3.5'
+ 'python-wrapio')
+optdepends=()
+md5sums=('7c42870b4f428de6b73948286ab30db7')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # Run python setup function
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ # Install the licence
+ install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/LICENCE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}