summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-03-09 17:26:53 -0700
committerMark Wagie2023-03-09 17:26:53 -0700
commit0097b6a565a8f26892c0d7d9efa17f5334f9d88d (patch)
tree1162b16cf526c634989d237ae0a321791ecf1be7
downloadaur-0097b6a565a8f26892c0d7d9efa17f5334f9d88d.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD25
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0db94685c5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-sv-ttk
+ pkgdesc = A gorgeous theme for ttk, based on Microsoft's Sun Valley visual styles
+ pkgver = 2.4
+ pkgrel = 1
+ url = https://github.com/rdbende/Sun-Valley-ttk-theme
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/sv_ttk/sv_ttk-2.4.tar.gz
+ sha256sums = 14c8186d9b933ea68f825f035d4e4b332a397de69f596e44d2db7c4e0acabd5f
+
+pkgname = python-sv-ttk
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e75cd04c09b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=python-sv-ttk
+_name=sv_ttk
+pkgver=2.4
+pkgrel=1
+pkgdesc="A gorgeous theme for ttk, based on Microsoft's Sun Valley visual styles"
+arch=('any')
+url="https://github.com/rdbende/Sun-Valley-ttk-theme"
+license=('MIT')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('14c8186d9b933ea68f825f035d4e4b332a397de69f596e44d2db7c4e0acabd5f')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}