summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Pitcher2022-09-25 09:24:34 -0700
committerBrad Pitcher2022-09-25 09:24:34 -0700
commite7f7cff64992a5e515bd0604010f6ecd901a5e4e (patch)
treed99de9dbc2fd8e5a9222042175370348b100de93
parent7f91d03d626f4786ac153079138eed2d2a6509af (diff)
downloadaur-e7f7cff64992a5e515bd0604010f6ecd901a5e4e.tar.gz
upgrade to version 6.2
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
3 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be8e13afb37..3de8b935c609 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-svg.path
pkgdesc = SVG path objects and parser
- pkgver = 4.1
- pkgrel = 3
+ pkgver = 6.2
+ pkgrel = 1
url = https://github.com/regebro/svg.path
arch = any
license = MIT
+ checkdepends = python-pillow
+ checkdepends = python-pytest
makedepends = python-setuptools
depends = python
- source = python-svg.path-4.1.tar.gz::https://github.com/regebro/svg.path/archive/4.1.tar.gz
- sha512sums = fb302c65f85bd61d98baab9e2a9707bc82f1bf02f3c9a34e5b864dcc7d2e03f85bd26a4fadd91a4249dbc37ae13f57eb5cdfc2805cbcb4f693d6f5c8863a3e92
+ source = python-svg.path-6.2.tar.gz::https://github.com/regebro/svg.path/archive/6.2.tar.gz
+ sha512sums = 7c9a67467e888f4961d54daf2706125c4ae21bb0cd1010f335eb072df78f12b1da99ddcf64a33a85a0e82a8b347f19e876161e3da8ebf43e5e7b45bbaf7d3325
pkgname = python-svg.path
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0b3adc04bd85
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.*
+python-svg.path-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0645b5c2c9f8..bc3219bf2d14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Jelle van der Waa <jelle@archlinux.org>
pkgname=python-svg.path
-pkgver=4.1
-pkgrel=3
+pkgver=6.2
+pkgrel=1
pkgdesc="SVG path objects and parser"
url="https://github.com/regebro/svg.path"
license=('MIT')
+checkdepends=(python-pillow python-pytest)
depends=(python)
makedepends=(python-setuptools)
arch=(any)
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/regebro/svg.path/archive/${pkgver}.tar.gz)
-sha512sums=('fb302c65f85bd61d98baab9e2a9707bc82f1bf02f3c9a34e5b864dcc7d2e03f85bd26a4fadd91a4249dbc37ae13f57eb5cdfc2805cbcb4f693d6f5c8863a3e92')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('7c9a67467e888f4961d54daf2706125c4ae21bb0cd1010f335eb072df78f12b1da99ddcf64a33a85a0e82a8b347f19e876161e3da8ebf43e5e7b45bbaf7d3325')
build() {
cd "svg.path-${pkgver}"