summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2018-06-25 22:14:53 +0100
committerEarnestly2018-06-25 22:14:53 +0100
commit2eca6a4cb1ff02217fdd8108b3f5245b5d23cb8e (patch)
tree317929d71e4af516177bed9ef7f58da2629f0f78
downloadaur-2eca6a4cb1ff02217fdd8108b3f5245b5d23cb8e.tar.gz
add python-svgwrite-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a0d2ecddaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-svgwrite-git
+ pkgdesc = write svg files
+ pkgver = 1.1.12.r1.g5ce5ed5
+ pkgrel = 1
+ url = https://github.com/mozman/svgwrite
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ provides = python-svgwrite
+ conflicts = python-svgwrite
+ source = git+https://github.com/mozman/svgwrite
+ sha256sums = SKIP
+
+pkgname = python-svgwrite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de7570d4d33a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=python-svgwrite-git
+pkgver=1.1.12.r1.g5ce5ed5
+pkgrel=1
+
+pkgdesc='write svg files'
+url='https://github.com/mozman/svgwrite'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+makedepends=('git' 'python-setuptools')
+
+provides=('python-svgwrite')
+conflicts=('python-svgwrite')
+
+source=('git+https://github.com/mozman/svgwrite')
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd svgwrite
+ git describe --long --tags | sed -r 's/^v//; s/([^-]*-g)/r\1/; s/-/./g'
+}
+
+build() {
+ cd svgwrite
+ python setup.py build
+}
+
+package() {
+ cd svgwrite
+ python setup.py install --root="$pkgdir" --optimize=1
+}