summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Stahlberg2020-12-17 15:09:36 +0100
committerMaximilian Stahlberg2020-12-17 15:09:36 +0100
commit29b1e407f135cbeda2dcd22e3e1cc18e2e27daa6 (patch)
tree7b778a6cfeed0f7110521c66c205df244f238cec
parent4494f154778af55aab61c999228a5e275687cb33 (diff)
downloadaur-29b1e407f135cbeda2dcd22e3e1cc18e2e27daa6.tar.gz
Work around a bug in setup.py.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a71d66494f6..550922335853 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-swiglpk
pkgdesc = A low-level Python interface to the GLPK optimization solver.
pkgver = 4.65.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/biosustain/swiglpk
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 0e50603a3487..7845caf9e668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-swiglpk
pkgver=4.65.1
-pkgrel=2
+pkgrel=3
pkgdesc='A low-level Python interface to the GLPK optimization solver.'
arch=('any')
url='https://github.com/biosustain/swiglpk'
@@ -12,6 +12,13 @@ makedepends=('swig' 'python-setuptools')
source=("https://github.com/biosustain/swiglpk/archive/${pkgver}.tar.gz")
+prepare() {
+ cd "${srcdir}/swiglpk-${pkgver}"
+
+ # Work around https://github.com/biosustain/swiglpk/issues/40.
+ cp /usr/include/glpk.h .
+}
+
package() {
cd "${srcdir}/swiglpk-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1