summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2023-01-24 08:06:49 +0000
committerWill Handley2023-01-24 08:06:49 +0000
commit4b8338f1d175fbde127ad9107650172559676549 (patch)
tree410c9f3c9a085225ae566cd620ca094e321953fb
downloadaur-4b8338f1d175fbde127ad9107650172559676549.tar.gz
first commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a602a5dd3c8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-swyft-git
+ pkgdesc = swyft is the official implementation of Truncated Marginal Neural Ratio Estimation (TMNRE), a hyper-efficient, simulation-based inference technique for complex data and expensive simulators.
+ pkgver = r1216.06cc085
+ pkgrel = 1
+ url = https://github.com/undark-lab/swyft
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-toolz
+ depends = python-numpy
+ depends = python-pytorch
+ depends = python-pytorch-lightning
+ depends = python-zarr
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-torchist
+ depends = python-fasteners
+ provides = python-swyft
+ conflicts = python-swyft
+ source = python-swyft::git+https://github.com/undark-lab/swyft.git
+ md5sums = SKIP
+
+pkgname = python-swyft-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6b8c850ccb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.tar.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb22770619a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_name=swyft
+pkgname=python-$_name-git
+pkgver=r1216.06cc085
+pkgrel=1
+pkgdesc="swyft is the official implementation of Truncated Marginal Neural Ratio Estimation (TMNRE), a hyper-efficient, simulation-based inference technique for complex data and expensive simulators."
+arch=(any)
+url="https://github.com/undark-lab/swyft"
+license=('Apache')
+groups=()
+depends=(python-toolz python-numpy python-pytorch python-pytorch-lightning python-zarr python-matplotlib python-scipy python-torchist python-fasteners)
+makedepends=(git python-setuptools)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+$url.git")
+noextract=()
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}