summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Gerritse2020-04-15 20:10:00 +0200
committerJohn Gerritse2020-04-15 20:10:00 +0200
commit3549fa5b3451ecfc44cd849958d4da1ba465423c (patch)
tree5d62af81b12a9c532ec53d2ef9598172b92ee991
downloadaur-3549fa5b3451ecfc44cd849958d4da1ba465423c.tar.gz
New PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b4463d7a3ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-symspellpy
+ pkgdesc = Python SymSpell
+ pkgver = 6.5.2
+ pkgrel = 1
+ url = https://github.com/mammothb/symspellpy
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ source = python-symspellpy-6.5.2.tar.gz::https://github.com/mammothb/symspellpy/archive/v6.5.2.tar.gz
+ sha256sums = 60c44186dd3a993f08887c09af14cb75635dff7570b5bf045f5d9360792e3fec
+
+pkgname = python-symspellpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11039f0cf4fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: John Gerritse <tyrannis dot hawk at gmail dot com>
+
+pkgname=python-symspellpy
+_pkgname=symspellpy
+pkgver=6.5.2
+pkgrel=1
+pkgdesc="Python SymSpell"
+arch=('any')
+url="https://github.com/mammothb/symspellpy"
+license=('MIT')
+depends=('python' 'python-setuptools')
+source=(
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/mammothb/symspellpy/archive/v${pkgver}.tar.gz
+)
+sha256sums=('60c44186dd3a993f08887c09af14cb75635dff7570b5bf045f5d9360792e3fec')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ LANG=en_US.UTF-8 python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ LANG=en_US.UTF-8 python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}