summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2024-03-07 13:28:25 +0530
committertxtsd2024-03-07 13:28:25 +0530
commit3ff94b9d63a8e6df3232bada99758793fbb7ce32 (patch)
treeca1c6e3d5eb89d63b6429763f41841e8e45688c5
parented34ccd964a8d7b14bf40aaaf41c47faedeeb2de (diff)
downloadaur-3ff94b9d63a8e6df3232bada99758793fbb7ce32.tar.gz
upgpkg: python-syncedlyrics 0.8.0-2
Switch to pypi Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21fa86a4a14f..d4de7956085e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-syncedlyrics
pkgdesc = Get an LRC format (synchronized) lyrics for your music
pkgver = 0.8.0
- pkgrel = 1
- url = https://github.com/0x7d4/syncedlyrics
+ pkgrel = 2
+ url = https://pypi.org/project/syncedlyrics
arch = any
license = MIT
checkdepends = python-pytest
@@ -14,7 +14,7 @@ pkgbase = python-syncedlyrics
depends = python-requests>=2.28.1
depends = python-rapidfuzz>=2.13.2
depends = python-beautifulsoup4>=4.11.1
- source = syncedlyrics-0.8.0.tar.gz::https://github.com/0x7d4/syncedlyrics/archive/v0.8.0.tar.gz
- sha256sums = 3daf9a31a9a488e50952940366b328eded9281a497ddf1962bb2f3cb6a47c474
+ source = https://pypi.org/packages/source/s/syncedlyrics/syncedlyrics-0.8.0.tar.gz
+ sha256sums = 494f40a0b34bb9a9389bb4ea2966007e480cdb91cbcc873573fe1bf191e428c7
pkgname = python-syncedlyrics
diff --git a/PKGBUILD b/PKGBUILD
index 59048d2ea149..d07d939705f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,29 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
pkgname=python-syncedlyrics
-_pkgname=syncedlyrics
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc='Get an LRC format (synchronized) lyrics for your music'
arch=('any')
-url="https://github.com/0x7d4/syncedlyrics"
+url='https://pypi.org/project/syncedlyrics'
license=('MIT')
depends=('python>=3.7' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
'python-beautifulsoup4>=4.11.1')
makedepends=('python-build' 'python-installer' 'python-wheel'
'python-poetry-core')
checkdepends=('python-pytest')
-source=("$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('3daf9a31a9a488e50952940366b328eded9281a497ddf1962bb2f3cb6a47c474')
+_module="${pkgname#python-}"
+_src_name="${_module/-/_}-${pkgver}"
+source=("https://pypi.org/packages/source/${_module::1}/${_module}/${_src_name}.tar.gz")
+sha256sums=('494f40a0b34bb9a9389bb4ea2966007e480cdb91cbcc873573fe1bf191e428c7')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_src_name}"
python -m build --wheel --no-isolation
}
-check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- pytest tests.py
-}
-
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_src_name}"
python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}