summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-09-15 10:30:15 +0300
committerPekka Ristola2023-09-15 10:30:15 +0300
commit47a2e04e21855bdfaa531975442166cf75985d30 (patch)
treef8ed17863ab259603c402f852b9b2bbc8ed354af
parentd09681e97cf1cbd9f961c4bfc9098605f62c5737 (diff)
downloadaur-47a2e04e21855bdfaa531975442166cf75985d30.tar.gz
Update to 0.6.0
- update upstream URL (the old URL redirects to the new URL) - remove unnecessary `conflicts` array - remove workaround for python-poetry-core bug that was fixed
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 028c0cf1c85e..6280f1ea8d1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-syncedlyrics
pkgdesc = Get an LRC format (synchronized) lyrics for your music
- pkgver = 0.5.0
- pkgrel = 2
- url = https://github.com/rtcq/syncedlyrics
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/0x7d4/syncedlyrics
arch = any
license = MIT
checkdepends = python-pytest
@@ -14,8 +14,7 @@ pkgbase = python-syncedlyrics
depends = python-requests>=2.28.1
depends = python-rapidfuzz>=2.13.2
depends = python-beautifulsoup4>=4.11.1
- conflicts = python-syncedlyrics-git
- source = syncedlyrics-0.5.0.tar.gz::https://github.com/rtcq/syncedlyrics/archive/refs/tags/v0.5.0.tar.gz
- sha256sums = 82d4315d753875c8e483dfad95e9c13bc5136fbd62e06bda6ce7b33b18c1fe26
+ source = syncedlyrics-0.6.0.tar.gz::https://github.com/0x7d4/syncedlyrics/archive/v0.6.0.tar.gz
+ sha256sums = 26491289f332d8a986eda844472ae72d9d15c7f7456dced628b27f325a98329b
pkgname = python-syncedlyrics
diff --git a/PKGBUILD b/PKGBUILD
index 4602bd4e349e..b296c78041ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,23 @@
pkgname=python-syncedlyrics
_pkgname=syncedlyrics
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.6.0
+pkgrel=1
pkgdesc='Get an LRC format (synchronized) lyrics for your music'
arch=('any')
-url='https://github.com/rtcq/syncedlyrics'
+url="https://github.com/0x7d4/syncedlyrics"
license=('MIT')
depends=('python>=3.7' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
'python-beautifulsoup4>=4.11.1')
makedepends=('python-build' 'python-installer' 'python-wheel'
'python-poetry-core')
checkdepends=('python-pytest')
-conflicts=("${pkgname}-git")
-source=("${_pkgname}-${pkgver}".tar.gz::"https://github.com/rtcq/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('82d4315d753875c8e483dfad95e9c13bc5136fbd62e06bda6ce7b33b18c1fe26')
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('26491289f332d8a986eda844472ae72d9d15c7f7456dced628b27f325a98329b')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- GIT_DIR=. python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation
}
check() {