summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2024-03-07 18:19:50 +0530
committertxtsd2024-03-07 18:19:50 +0530
commitf8ea971e7db79c7ac9fa8012e817ffcd1a3d6dad (patch)
tree9b84a2340d55a5759110857517cdcc52ef6b0f65
parent3ff94b9d63a8e6df3232bada99758793fbb7ce32 (diff)
downloadaur-f8ea971e7db79c7ac9fa8012e817ffcd1a3d6dad.tar.gz
upgpkg: python-syncedlyrics 0.8.0-3
Switch back to github source Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4de7956085e..e7d997a4e3b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-syncedlyrics
pkgdesc = Get an LRC format (synchronized) lyrics for your music
pkgver = 0.8.0
- pkgrel = 2
- url = https://pypi.org/project/syncedlyrics
+ pkgrel = 3
+ url = https://github.com/moehmeni/syncedlyrics
arch = any
license = MIT
checkdepends = python-pytest
@@ -10,11 +10,11 @@ pkgbase = python-syncedlyrics
makedepends = python-installer
makedepends = python-wheel
makedepends = python-poetry-core
- depends = python>=3.7
+ depends = python>=3.8
depends = python-requests>=2.28.1
depends = python-rapidfuzz>=2.13.2
depends = python-beautifulsoup4>=4.11.1
- source = https://pypi.org/packages/source/s/syncedlyrics/syncedlyrics-0.8.0.tar.gz
- sha256sums = 494f40a0b34bb9a9389bb4ea2966007e480cdb91cbcc873573fe1bf191e428c7
+ source = syncedlyrics-0.8.0.tar.gz::https://github.com/moehmeni/syncedlyrics/archive/refs/tags/v0.8.0.tar.gz
+ sha256sums = 3daf9a31a9a488e50952940366b328eded9281a497ddf1962bb2f3cb6a47c474
pkgname = python-syncedlyrics
diff --git a/PKGBUILD b/PKGBUILD
index d07d939705f4..f35ec9073c76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,33 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
pkgname=python-syncedlyrics
+_pkgname=${pkgname#python-}
pkgver=0.8.0
-pkgrel=2
+pkgrel=3
pkgdesc='Get an LRC format (synchronized) lyrics for your music'
arch=('any')
-url='https://pypi.org/project/syncedlyrics'
+url='https://github.com/moehmeni/syncedlyrics'
license=('MIT')
-depends=('python>=3.7' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
+depends=('python>=3.8' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
'python-beautifulsoup4>=4.11.1')
makedepends=('python-build' 'python-installer' 'python-wheel'
'python-poetry-core')
checkdepends=('python-pytest')
-_module="${pkgname#python-}"
-_src_name="${_module/-/_}-${pkgver}"
-source=("https://pypi.org/packages/source/${_module::1}/${_module}/${_src_name}.tar.gz")
-sha256sums=('494f40a0b34bb9a9389bb4ea2966007e480cdb91cbcc873573fe1bf191e428c7')
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('3daf9a31a9a488e50952940366b328eded9281a497ddf1962bb2f3cb6a47c474')
build() {
- cd "${_src_name}"
+ cd "${_pkgname}-${pkgver}"
python -m build --wheel --no-isolation
}
+check() {
+ cd "${_pkgname}-${pkgver}"
+ pytest tests.py
+}
+
package() {
- cd "${_src_name}"
+ cd "${_pkgname}-${pkgver}"
python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}