summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriele Musco2021-11-10 18:31:08 +0100
committerGabriele Musco2021-11-10 18:31:08 +0100
commit29f1805d9dc3bda33c5ea218176db64806e9fa90 (patch)
tree22ed320a685b13cb92119083fe3f795c43b149b1
parentfca6d148460aa9d5857a5e986846bf19d362e6ae (diff)
downloadaur-29f1805d9dc3bda33c5ea218176db64806e9fa90.tar.gz
updated dependencies and build options
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dc85a9691ce..f0b6399c79c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-syndom-git
pkgdesc = A simple RSS/Atom parser library in C++, with python bindings
- pkgver = 3f92efe
+ pkgver = 8c9344c
pkgrel = 1
url = https://gitlab.com/gabmus/syndication-domination
arch = any
@@ -10,6 +10,7 @@ pkgbase = python-syndom-git
depends = python
depends = pugixml
depends = pybind11
+ depends = tidy
provides = python-syndom
conflicts = python-syndom
source = python-syndom::git+https://gitlab.com/GabMus/syndication-domination.git
diff --git a/PKGBUILD b/PKGBUILD
index 23785f363160..786ce3674faf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Upstream URL: https://gitlab.com/gabmus/syndication-domination
pkgname=python-syndom-git
-pkgver=3f92efe
+pkgver=8c9344c
pkgrel=1
pkgdesc="A simple RSS/Atom parser library in C++, with python bindings"
arch=('any')
url="https://gitlab.com/gabmus/syndication-domination"
license=('AGPL3')
-depends=('python' 'pugixml' 'pybind11')
+depends=('python' 'pugixml' 'pybind11' 'tidy')
makedepends=('git' 'meson')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -22,8 +22,9 @@ pkgver() {
build() {
arch-meson \
- -Dpython_bindings=true \
- -Dto_json_binary=false \
+ -DPYTHON_BINDINGS=true \
+ -DTO_JSON_BINARY=false \
+ -DHTML_SUPPORT=true \
"${pkgname%-git}" build
meson compile -C build
}