summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-27 16:32:45 -0500
committerCarlos Aznarán Laos2022-10-27 16:32:45 -0500
commit1257ca00fabe59acc50fe3b0c23df688aeb4af4c (patch)
tree2025d0f84fca3fb2253579a900d20cb73b9061aa
parentdaecee2dc8d25da0cc15dc0936b969b8f2bdf588 (diff)
downloadaur-1257ca00fabe59acc50fe3b0c23df688aeb4af4c.tar.gz
Use Pypi source
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 6 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9e90ade6728..ad52fa816fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-syrupy
pkgdesc = The sweeter pytest snapshot plugin
pkgver = 3.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tophat/syrupy
arch = any
license = Apache
@@ -10,7 +10,7 @@ pkgbase = python-syrupy
makedepends = python-poetry-core
depends = python-pytest
depends = python-colored
- source = syrupy-3.0.2.tar.gz::https://github.com/tophat/syrupy/archive/v3.0.2.tar.gz
- sha512sums = ccb2e07343d718e3293d5756f318ce9234d5903ca4b3fe0006b8fa19c1bf30ede9e52d99e75480622c6db5680aded6ecea13a88dfe8095f7e54656a2d61f26ff
+ source = https://pypi.org/packages/source/s/syrupy/syrupy-3.0.2.tar.gz
+ sha512sums = a03568894460d9a3f525be5e499fd9067e8519b60934e406132a5b7afbea4e3ac848dd0c006bb135fc79f7fd2f4c1e0467c4194b19553039f3c3e6006fc2e06f
pkgname = python-syrupy
diff --git a/PKGBUILD b/PKGBUILD
index 042f463cc59e..b81415cee8b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,20 @@ _base=syrupy
pkgname=python-${_base}
pkgdesc="The sweeter pytest snapshot plugin"
pkgver=3.0.2
-pkgrel=2
+pkgrel=3
arch=(any)
url="https://github.com/tophat/${_base}"
license=(Apache)
depends=(python-pytest python-colored)
makedepends=(python-build python-installer python-poetry-core)
-source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('ccb2e07343d718e3293d5756f318ce9234d5903ca4b3fe0006b8fa19c1bf30ede9e52d99e75480622c6db5680aded6ecea13a88dfe8095f7e54656a2d61f26ff')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('a03568894460d9a3f525be5e499fd9067e8519b60934e406132a5b7afbea4e3ac848dd0c006bb135fc79f7fd2f4c1e0467c4194b19553039f3c3e6006fc2e06f')
build() {
cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
-# check() {
-# cd ${_base}-${pkgver}
-# python -m venv --system-site-packages test-env
-# test-env/bin/python -m installer dist/*.whl
-# test-env/bin/python -m pytest
-# }
-
package() {
cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl