summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-25 15:35:49 -0500
committerCarlos Aznarán Laos2022-10-25 15:35:49 -0500
commit22df8850fe45280117bc68ff503aa3fea6be8e8d (patch)
treeb2b29ee6085515caff0870b37c16dc8fd5e0a4a8
downloadaur-22df8850fe45280117bc68ff503aa3fea6be8e8d.tar.gz
Bump version to 3.0.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bd6c8e660d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-syrupy
+ pkgdesc = The sweeter pytest snapshot plugin
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://github.com/tophat/syrupy
+ arch = any
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry-core
+ depends = python-pytest
+ depends = python-colored
+ source = syrupy-3.0.2.tar.gz::https://github.com/tophat/syrupy/archive/v3.0.2.tar.gz
+ sha512sums = ccb2e07343d718e3293d5756f318ce9234d5903ca4b3fe0006b8fa19c1bf30ede9e52d99e75480622c6db5680aded6ecea13a88dfe8095f7e54656a2d61f26ff
+
+pkgname = python-syrupy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1446618554d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=syrupy
+pkgname=python-${_base}
+pkgdesc="The sweeter pytest snapshot plugin"
+pkgver=3.0.2
+pkgrel=1
+arch=(any)
+url="https://github.com/tophat/${_base}"
+license=(Apache)
+depends=(python-pytest python-colored)
+makedepends=(python-build python-installer python-poetry-core)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('ccb2e07343d718e3293d5756f318ce9234d5903ca4b3fe0006b8fa19c1bf30ede9e52d99e75480622c6db5680aded6ecea13a88dfe8095f7e54656a2d61f26ff')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}