summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-07-12 14:10:49 -0500
committerCarlos Aznarán Laos2023-07-12 14:10:49 -0500
commitc86a2ae2916a2ce6f9b1e86314f6bf6fb8fe082c (patch)
treeaf48c6d71e47db3816521bc35e3f171953aab24f
parent3297a3702b6f8c7302cf5f3edfb2fe35d7feb6e7 (diff)
downloadaur-c86a2ae2916a2ce6f9b1e86314f6bf6fb8fe082c.tar.gz
Bump version to 4.0.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7279a767b7fe..3c3e33c4255b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-syrupy
- pkgdesc = The sweeter pytest snapshot plugin
- pkgver = 4.0.5
+ pkgdesc = Pytest Snapshot Test Utility
+ pkgver = 4.0.6
pkgrel = 1
url = https://github.com/tophat/syrupy
arch = any
@@ -10,7 +10,7 @@ pkgbase = python-syrupy
makedepends = python-poetry-core
depends = python-pytest
depends = python-colored
- source = syrupy-4.0.5.tar.gz::https://github.com/tophat/syrupy/archive/v4.0.5.tar.gz
- sha512sums = 20053069cb81e4e0c13e3a4c9ec5fe886e34d59a24bd1e2035b408183de45bd033faf4d56282260e21cf63fabe58bab31850fa592ccac731e8bf765f1469bb8f
+ source = syrupy-4.0.6.tar.gz::https://github.com/tophat/syrupy/archive/v4.0.6.tar.gz
+ sha512sums = f087d06415d12840de53df8a18c8505b5d65fc4e8597b77a892fbc8020b6f5b8e9d299ab4a199ab25fbbee0bfde1977a871f1aec717aa1379b69f5b607cf815a
pkgname = python-syrupy
diff --git a/PKGBUILD b/PKGBUILD
index 5b7ef2a11694..995359963549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=syrupy
pkgname=python-${_base}
-pkgdesc="The sweeter pytest snapshot plugin"
-pkgver=4.0.5
+pkgdesc="Pytest Snapshot Test Utility"
+pkgver=4.0.6
pkgrel=1
arch=(any)
url="https://github.com/tophat/${_base}"
license=(Apache)
depends=(python-pytest python-colored)
makedepends=(python-build python-installer python-poetry-core)
+checkdepens=()
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('20053069cb81e4e0c13e3a4c9ec5fe886e34d59a24bd1e2035b408183de45bd033faf4d56282260e21cf63fabe58bab31850fa592ccac731e8bf765f1469bb8f')
+sha512sums=('f087d06415d12840de53df8a18c8505b5d65fc4e8597b77a892fbc8020b6f5b8e9d299ab4a199ab25fbbee0bfde1977a871f1aec717aa1379b69f5b607cf815a')
build() {
cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
-# check() {
-# cd ${_base}-${pkgver}
-# python -m venv --system-site-packages test-env
-# test-env/bin/python -m installer dist/*.whl
-# test-env/bin/python -m pytest #-k 'not update_failure_shows_snapshot_diff'
-# }
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
+}
package() {
cd ${_base}-${pkgver}