summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfl0w12017-12-18 12:40:23 +0100
committerfl0w12017-12-18 12:40:23 +0100
commit062265cd7390e3c466b0d0cf05818123004711c2 (patch)
tree7cbb30468955bf853add8268555aceb9baec93d3
downloadaur-062265cd7390e3c466b0d0cf05818123004711c2.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc7922020698
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-tabledata
+ pkgdesc = A Python library to represent tabular data for pytablewriter/pytablereader/SimpleSQLite.
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/thombashi/tabledata
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pathvalidate>=0.16.2
+ depends = python-dataproperty>=0.29.1
+ depends = python-logbook>=1.1.0
+ depends = python-six
+ depends = python-typepy>=0.0.20
+ source = https://github.com/thombashi/tabledata/archive/v0.0.5.tar.gz
+ md5sums = 7b6256da07b2381c50cb8db8df1241f9
+
+pkgname = python-tabledata
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd090699b816
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname='python-tabledata'
+_module='tabledata'
+pkgver='0.0.5'
+pkgrel=1
+pkgdesc="A Python library to represent tabular data for pytablewriter/pytablereader/SimpleSQLite."
+url="https://github.com/thombashi/tabledata"
+depends=('python' 'python-pathvalidate>=0.16.2' 'python-dataproperty>=0.29.1' 'python-logbook>=1.1.0' 'python-six' 'python-typepy>=0.0.20')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://github.com/thombashi/tabledata/archive/v${pkgver}.tar.gz")
+md5sums=('7b6256da07b2381c50cb8db8df1241f9')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}