summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-15 22:56:07 +0100
committerNarrat2020-01-15 22:56:07 +0100
commit5837ca9832394a6f912e1ebb4456ec915cf4c8ff (patch)
tree7b9eedab83451d5b83e8344e2534df00d468bed6
parent2791441075a5a6ba600a3d75aee60481fa190c72 (diff)
downloadaur-5837ca9832394a6f912e1ebb4456ec915cf4c8ff.tar.gz
update to 1.0.0 which dropped python2 support
And add all optdeps
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD55
-rw-r--r--remove-locale-from-str-regex.patch54
3 files changed, 36 insertions, 96 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acbdd0bc433d..98e384337b08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
-# Generated by mksrcinfo v8
-# Fri Jan 13 03:39:36 UTC 2017
pkgbase = python-tablib
pkgdesc = Format-agnostic tabular data library (XLS, JSON, YAML, CSV)
- pkgver = 0.11.3
+ pkgver = 1.0.0
pkgrel = 1
url = http://python-tablib.org
arch = any
license = MIT
checkdepends = python-pytest
- checkdepends = python2-pytest
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://pypi.python.org/packages/12/93/2bdd501dad13f253cfc8bd066ff18313e4741c1c11d336dd9bbd78aa7845/tablib-0.11.3.tar.gz
- source = remove-locale-from-str-regex.patch
- sha256sums = 6369662b116a7ed7a13545ebac266c063f170ff9215e918ba01a1ef20a864c9a
+ depends = python
+ optdepends = python-tabulate: cli interface
+ optdepends = python-markuppy: for HTML support
+ optdepends = python-odfpy: for ODS support
+ optdepends = python-pandas: for pandas support
+ optdepends = python-xlrd: for XLS support (extract data)
+ optdepends = python-xlwt: for XLS support (create spreadsheets)
+ optdepends = python-openpyxl: for XLSX support
+ optdepends = python-pyaml: for YAML support
+ source = https://files.pythonhosted.org/packages/source/t/tablib/tablib-1.0.0.tar.gz
+ sha256sums = ff3172802e8dd7fb795867942f5238f6c90e2d4e90ad6233c1a796cdfc63bb35
sha256sums = 18ba282dbdc710edfda125ba80ca97a46bf9eb7e6183dc11eb1a47825f3b12ae
pkgname = python-tablib
- depends = python
-
-pkgname = python2-tablib
diff --git a/PKGBUILD b/PKGBUILD
index 821bbb42e01c..c60dd175e355 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,43 @@
-# Maintainer: David Scholl <djscholl at gmail dot com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: David Scholl <djscholl at gmail dot com>
+
_module="tablib"
-pkgname=("python-${_module}" "python2-${_module}")
-pkgver="0.11.3"
-pkgrel="1"
+pkgname="python-${_module}"
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Format-agnostic tabular data library (XLS, JSON, YAML, CSV)"
arch=("any")
url="http://python-tablib.org"
license=("MIT")
-makedepends=("python-setuptools" "python2-setuptools")
-checkdepends=("python-pytest" "python2-pytest")
-source=("https://pypi.python.org/packages/12/93/2bdd501dad13f253cfc8bd066ff18313e4741c1c11d336dd9bbd78aa7845/${_module}-${pkgver}.tar.gz"
- 'remove-locale-from-str-regex.patch')
-sha256sums=('6369662b116a7ed7a13545ebac266c063f170ff9215e918ba01a1ef20a864c9a'
+depends=("python")
+makedepends=("python-setuptools")
+checkdepends=("python-pytest")
+optdepends=("python-tabulate: cli interface"
+ "python-markuppy: for HTML support"
+ "python-odfpy: for ODS support"
+ "python-pandas: for pandas support"
+ "python-xlrd: for XLS support (extract data)"
+ "python-xlwt: for XLS support (create spreadsheets)"
+ "python-openpyxl: for XLSX support"
+ "python-pyaml: for YAML support")
+source=(https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz)
+sha256sums=('ff3172802e8dd7fb795867942f5238f6c90e2d4e90ad6233c1a796cdfc63bb35'
'18ba282dbdc710edfda125ba80ca97a46bf9eb7e6183dc11eb1a47825f3b12ae')
-prepare() {
- cd "${srcdir}/${_module}-${pkgver}"
- patch -p1 < ${srcdir}/remove-locale-from-str-regex.patch
- cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
-}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py build
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py build
}
check() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
PYTHONPATH="$PWD/build/lib:$PYTHONPATH" py.test
- cd "${srcdir}/${_module}-${pkgver}-python2"
- PYTHONPATH="$PWD/build/lib:$PYTHONPATH" py.test2
}
-package_python-tablib() {
- depends=("python")
- cd "${srcdir}/${_module}-${pkgver}"
+package() {
+ cd "${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -D -m644 "${srcdir}/${_module}-${pkgver}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-package_python2-tablib() {
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -D -m644 "${srcdir}/${_module}-${pkgver}-python2/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+} \ No newline at end of file
diff --git a/remove-locale-from-str-regex.patch b/remove-locale-from-str-regex.patch
deleted file mode 100644
index f2b1294f2d68..000000000000
--- a/remove-locale-from-str-regex.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 54f9041f2c3cd47643bf4b9183f8cb530caf6313 Mon Sep 17 00:00:00 2001
-From: Andrii Soldatenko <andrii.soldatenko@ethoos.com>
-Date: Sun, 18 Dec 2016 16:44:18 +0200
-Subject: [PATCH] Remove LOCALE from str regular expression
-
----
- tablib/packages/xlwt/ExcelFormulaLexer.py | 4 ++--
- tablib/packages/xlwt3/ExcelFormulaLexer.py | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tablib/packages/xlwt/ExcelFormulaLexer.py b/tablib/packages/xlwt/ExcelFormulaLexer.py
-index 91d999f..5004d8e 100644
---- a/tablib/packages/xlwt/ExcelFormulaLexer.py
-+++ b/tablib/packages/xlwt/ExcelFormulaLexer.py
-@@ -4,7 +4,7 @@
- from antlr import EOF, CommonToken as Tok, TokenStream, TokenStreamException
- import struct
- import ExcelFormulaParser
--from re import compile as recompile, match, LOCALE, UNICODE, IGNORECASE, VERBOSE
-+from re import compile as recompile, match, UNICODE, IGNORECASE, VERBOSE
-
-
- int_const_pattern = r"\d+\b"
-@@ -51,7 +51,7 @@
-
- _re = recompile(
- '(' + ')|('.join([i[0] for i in pattern_type_tuples]) + ')',
-- VERBOSE+LOCALE+IGNORECASE)
-+ VERBOSE+IGNORECASE)
-
- _toktype = [None] + [i[1] for i in pattern_type_tuples]
- # need dummy at start because re.MatchObject.lastindex counts from 1
-diff --git a/tablib/packages/xlwt3/ExcelFormulaLexer.py b/tablib/packages/xlwt3/ExcelFormulaLexer.py
-index 5dc546c..9b6103c 100644
---- a/tablib/packages/xlwt3/ExcelFormulaLexer.py
-+++ b/tablib/packages/xlwt3/ExcelFormulaLexer.py
-@@ -2,7 +2,7 @@
- from .antlr import EOF, CommonToken as Tok, TokenStream, TokenStreamException
- import struct
- from . import ExcelFormulaParser
--from re import compile as recompile, match, LOCALE, UNICODE, IGNORECASE, VERBOSE
-+from re import compile as recompile, match, UNICODE, IGNORECASE, VERBOSE
-
-
- int_const_pattern = r"\d+\b"
-@@ -49,7 +49,7 @@
-
- _re = recompile(
- '(' + ')|('.join([i[0] for i in pattern_type_tuples]) + ')',
-- VERBOSE+LOCALE+IGNORECASE)
-+ VERBOSE+IGNORECASE)
-
- _toktype = [None] + [i[1] for i in pattern_type_tuples]
- # need dummy at start because re.MatchObject.lastindex counts from 1