summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArun Mahapatra2020-04-26 09:59:50 +0530
committerArun Mahapatra2020-04-26 09:59:50 +0530
commit733214963f99a81c106d84834ad99236883336cd (patch)
treeeb6b5dc38160d3ed3657b825c2528fadcee1b377
parentad2be60891f3943df593f5285ed5621f95fabdbd (diff)
downloadaur-python-tabula.tar.gz
chore: fix namcap error and srcinfo
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a04b56c541c..1187400ec07c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tabula
pkgdesc = Simple wrapper for tabula, read tables from PDF into DataFrame
- pkgver = 1.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/chezou/tabula-py
arch = any
@@ -12,8 +12,8 @@ pkgbase = python-tabula
depends = python-requests
depends = python-numpy
provides = python-tabula
- source = python-tabula-1.0.0.tar.gz::https://github.com/chezou/tabula-py/archive/v1.0.0.tar.gz
- sha512sums = 24db1a2df9c247a4fd1523849870e0880c0c1d28099799fedb8d3a520b08dd397282147d4de7ce353ce82d884271c61b4bcfe01dae95b9ed38b804ec3f6be063
+ source = https://files.pythonhosted.org/packages/source/t/tabula-py/tabula-py-2.1.0.tar.gz
+ sha512sums = 91d1005d4873322a4da24191aafc20f8498d8c548696169a6a8f18392a2ff9f6049e26f1406a5d553c47c20de94ac310819a9019ec7b8d53a11401ebb6642602
pkgname = python-tabula
diff --git a/PKGBUILD b/PKGBUILD
index 2c86ff3e2bec..3b9e4434471b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,16 +10,15 @@ arch=('any')
provides=('python-tabula')
makedepends=('python-setuptools')
depends=('java-runtime' 'python' 'python-pandas' 'python-requests' 'python-numpy')
-sourcename="tabula-py"
_name="tabula-py"
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/${_name}-$pkgver.tar.gz")
sha512sums=('91d1005d4873322a4da24191aafc20f8498d8c548696169a6a8f18392a2ff9f6049e26f1406a5d553c47c20de94ac310819a9019ec7b8d53a11401ebb6642602')
prepare() {
- cd "${srcdir}/${sourcename}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
}
package() {
- cd "${srcdir}/${sourcename}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
}