summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-09-16 22:44:23 +1000
committerMatthew Gamble2015-09-16 22:44:23 +1000
commit823e6d2fd892c3062ce832d957098c2ee0b10e3c (patch)
treee8adf1dcd6fdb3ec878eb004af830bb19d9aaf46
downloadaur-823e6d2fd892c3062ce832d957098c2ee0b10e3c.tar.gz
Initial import of package to AUR4 (with version bump included)
Last version in AUR3 was 0.7.2. New version is 0.7.5.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46b6e9910ae2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-tabulate
+ pkgdesc = Pretty-print tabular data in Python.
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://bitbucket.org/astanin/python-tabulate
+ arch = any
+ license = MIT
+ depends = python
+ source = https://pypi.python.org/packages/source/t/tabulate/tabulate-0.7.5.tar.gz
+ sha256sums = 9071aacbd97a9a915096c1aaf0dc684ac2672904cd876db5904085d6dac9810e
+
+pkgname = python-tabulate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bec705430344
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matthew Gamble
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
+
+pkgname=python-tabulate
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Pretty-print tabular data in Python."
+arch=("any")
+license=("MIT")
+url="https://bitbucket.org/astanin/python-tabulate"
+depends=("python")
+source=("https://pypi.python.org/packages/source/t/tabulate/tabulate-${pkgver}.tar.gz")
+sha256sums=('9071aacbd97a9a915096c1aaf0dc684ac2672904cd876db5904085d6dac9810e')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}