summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2017-12-16 13:47:39 +1100
committerMatthew Gamble2017-12-16 13:47:39 +1100
commitd7c680056c0237f68533cb2f7d3cc37070c4e8c0 (patch)
tree595bd11f4ec0f24a24f62d2deda6facd9b5fa7ed
parent46c351345f5d4318ffe59e22cb5645dff3b47ed8 (diff)
downloadaur-d7c680056c0237f68533cb2f7d3cc37070c4e8c0.tar.gz
Update to latest version, include license file, add gitignore
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD7
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d31c13a07dd..aa38109c7126 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Sun Dec 25 02:45:59 UTC 2016
+# Sat Dec 16 02:46:09 UTC 2017
pkgbase = python-tabulate
pkgdesc = Pretty-print tabular data in Python
- pkgver = 0.7.7
+ pkgver = 0.8.2
pkgrel = 1
url = https://bitbucket.org/astanin/python-tabulate
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = https://pypi.python.org/packages/1c/a1/3367581782ce79b727954f7aa5d29e6a439dc2490a9ac0e7ea0a7115435d/tabulate-0.7.7.tar.gz
- sha512sums = 36ea77577e36fad28efa9b1c10686a4a795acdea77be4f8b442b38f45d70993245b4b473b0ce146f3d24eb49f186ec47ada332a9a3973ac2786d5a46b7358213
+ source = https://pypi.python.org/packages/12/c2/11d6845db5edf1295bc08b2f488cf5937806586afe42936c3f34c097ebdc/tabulate-0.8.2.tar.gz
+ sha512sums = 9e34fb84e16f4b2c1378c0f53c5ef803438fcae7bc1637ac8975f358a11653f641bba0ea19529858e8e62aa45bb5bccd3b6f0492fd2d9d9c9a3bf963dd1ac0a7
pkgname = python-tabulate
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..24b875e604eb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 01b0a3d7153d..cd08465e8d3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jerome Leclanche <jerome@leclan.ch>
pkgname=python-tabulate
-pkgver=0.7.7
+pkgver=0.8.2
pkgrel=1
pkgdesc="Pretty-print tabular data in Python"
arch=("any")
@@ -10,8 +10,8 @@ license=("MIT")
url="https://bitbucket.org/astanin/python-tabulate"
depends=("python")
makedepends=("python-setuptools")
-source=("https://pypi.python.org/packages/1c/a1/3367581782ce79b727954f7aa5d29e6a439dc2490a9ac0e7ea0a7115435d/tabulate-${pkgver}.tar.gz")
-sha512sums=('36ea77577e36fad28efa9b1c10686a4a795acdea77be4f8b442b38f45d70993245b4b473b0ce146f3d24eb49f186ec47ada332a9a3973ac2786d5a46b7358213')
+source=("https://pypi.python.org/packages/12/c2/11d6845db5edf1295bc08b2f488cf5937806586afe42936c3f34c097ebdc/tabulate-${pkgver}.tar.gz")
+sha512sums=("9e34fb84e16f4b2c1378c0f53c5ef803438fcae7bc1637ac8975f358a11653f641bba0ea19529858e8e62aa45bb5bccd3b6f0492fd2d9d9c9a3bf963dd1ac0a7")
build() {
cd "tabulate-${pkgver}"
@@ -21,4 +21,5 @@ build() {
package() {
cd "tabulate-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-tabulate/LICENSE"
}