summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-09-28 15:01:28 +0800
committerPumpkinCheshire2021-09-28 15:01:28 +0800
commit80757a58a82d4f072ed6f502170203fd8f78df34 (patch)
tree6ca88fd96d2bf65cfde41239880884b3b3db4a85
parent8a784d9df7945d55fd7fc288c32184e792fe00f7 (diff)
downloadaur-80757a58a82d4f072ed6f502170203fd8f78df34.tar.gz
bump to 0.8.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51eb0dd727c1..e8c8e0dde562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-taichi
pkgdesc = Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs
- pkgver = 0.7.32
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/taichi-dev/taichi
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = python-taichi
optdepends = python-gitpython
optdepends = yapf
optdepends = cuda
- source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.7.32-cp39-cp39-manylinux1_x86_64.whl
- b2sums = 7c4efa1e4a48975ace862fe72d209bd655080c4aed749ec801782b4f198ab0c9272a1b381a4f0b416f3784f1b5335392aa90022a8c77a1f0a9ba5e76bb47a3c4
+ source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.8.0-cp39-cp39-manylinux1_x86_64.whl
+ b2sums = 97b1bfeb4176f5b5b17e3c8c91f5589f7c76f21aa7ddcfadab913d59e135c9f2daa1823e402dfe6e20234f1d43ceebbd784f9d3657b226e95ac4af243f8db516
pkgname = python-taichi
diff --git a/PKGBUILD b/PKGBUILD
index a1d52f804235..8744fe517b32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
#!/bin/bash
-# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
pkgname=python-taichi
_name=${pkgname#python-}
_py=cp39
-pkgver=0.7.32
+pkgver=0.8.0
pkgrel=1
pkgdesc='Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs'
url='https://github.com/taichi-dev/taichi'
@@ -31,7 +31,7 @@ optdepends=(
'cuda')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name//-/_}-$pkgver-$_py-$_py-manylinux1_x86_64.whl")
-b2sums=('7c4efa1e4a48975ace862fe72d209bd655080c4aed749ec801782b4f198ab0c9272a1b381a4f0b416f3784f1b5335392aa90022a8c77a1f0a9ba5e76bb47a3c4')
+b2sums=('97b1bfeb4176f5b5b17e3c8c91f5589f7c76f21aa7ddcfadab913d59e135c9f2daa1823e402dfe6e20234f1d43ceebbd784f9d3657b226e95ac4af243f8db516')
package() {
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-warn-script-location --no-deps ${_name//-/_}-$pkgver-$_py-$_py-manylinux1_x86_64.whl