summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-07-01 01:17:13 +0800
committerPumpkinCheshire2021-07-01 01:17:13 +0800
commitb1c811a362a53cae0e9b4a9ed35ce7ee72c32341 (patch)
tree3cb906a8facff5b85b3bb09702c80b0571982861
parent22ced4e7e48ae8de744a8f648a5aef05ebe276af (diff)
downloadaur-b1c811a362a53cae0e9b4a9ed35ce7ee72c32341.tar.gz
bump to 0.7.24
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5dafd393288..19db4e674416 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-taichi
pkgdesc = Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs
- pkgver = 0.7.23
+ pkgver = 0.7.24
pkgrel = 1
url = https://github.com/taichi-dev/taichi
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = python-taichi
optdepends = python-gitpython
optdepends = yapf
optdepends = cuda
- source = https://files.pythonhosted.org/packages/18/70/df5fb2533f6a4f58dc6c570ad77ba28e899aefa916b57ba3f2a58b897615/taichi-0.7.23-cp39-cp39-manylinux1_x86_64.whl
- b2sums = bba5bc8a21ee590288fa78d23d56d51c054ed9b168754b1c93add0db3f6e19a4622fc0e49a29952cb455f74e6bbf8889e7b0724138afb1c75e5484b15871e2b4
+ source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.7.24-cp39-cp39-manylinux1_x86_64.whl
+ b2sums = 6f0f99ced428b080ab140bcb71d87340c917e30cfb5df916e2b0502850cc29cecdc766e618d01d7e5232995ff147d22c575a8315c7226a86f87ef0e02a7e8654
pkgname = python-taichi
diff --git a/PKGBUILD b/PKGBUILD
index a63fa44b0b0a..30853b9da3c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
pkgname='python-taichi'
-_name='taichi'
-pkgver=0.7.23
+_name=${pkgname#python-}
+_py='cp39'
+pkgver=0.7.24
pkgrel=1
pkgdesc="Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs"
arch=('x86_64')
@@ -25,14 +26,23 @@ optdepends=('python-autograd'
'cuda')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/18/70/df5fb2533f6a4f58dc6c570ad77ba28e899aefa916b57ba3f2a58b897615/taichi-0.7.23-cp39-cp39-manylinux1_x86_64.whl")
+source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name//-/_}-$pkgver-$_py-${_py}-manylinux1_x86_64.whl")
-b2sums=('bba5bc8a21ee590288fa78d23d56d51c054ed9b168754b1c93add0db3f6e19a4622fc0e49a29952cb455f74e6bbf8889e7b0724138afb1c75e5484b15871e2b4')
+b2sums=('6f0f99ced428b080ab140bcb71d87340c917e30cfb5df916e2b0502850cc29cecdc766e618d01d7e5232995ff147d22c575a8315c7226a86f87ef0e02a7e8654')
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-warn-script-location --no-deps ${_name//-/_}-$pkgver-$_py-${_py}-manylinux1_x86_64.whl
- python -O -m compileall -p "${pkgdir}" "${pkgdir}"
+ cd $pkgdir/usr/lib/python3.9/site-packages/$_name/
+ # remove pyc and compile by my self
+ find . -name "*.pyc" | xargs rm -rf
+
+ # remove prefix
+ python -O -m compileall -f "${pkgdir}/usr/lib/python3.9/site-packages/$_name/" -s "${pkgdir}" -p "/"
+
+ # manually rewrite direct_url.json
+ cd $pkgdir/usr/lib/python3.9/site-packages/$_name-$pkgver.dist-info/
+ echo "{\"archive_info\": {\"hash\": \"b2sums=$b2sums\"}, \"url\": \"$source\"}" >direct_url.json
install -Dm644 "$srcdir/$_name-$pkgver.dist-info/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}