summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-08-06 14:03:26 +0800
committerPumpkinCheshire2021-08-06 14:03:26 +0800
commitdcf32e847b03e3cf2c521256ae1b37670826a2d5 (patch)
tree0890bac05678944146bd3fdbb621f2998546bfa9
parentff4b7c174517a88bb8fae0a15a735c1488f9c078 (diff)
downloadaur-dcf32e847b03e3cf2c521256ae1b37670826a2d5.tar.gz
bump to 0.7.28
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD43
2 files changed, 26 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 643d198a54bd..7a89ce589f8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-taichi
pkgdesc = Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs
- pkgver = 0.7.26
+ pkgver = 0.7.28
pkgrel = 1
url = https://github.com/taichi-dev/taichi
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = python-taichi
optdepends = python-gitpython
optdepends = yapf
optdepends = cuda
- source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.7.26-cp39-cp39-manylinux1_x86_64.whl
- b2sums = a0efba9e913013cbae8b0d8e7bac1dfe5a91abfee12be961e69cfabea614e0fbc1b124694264a561d7ecd3863964a42dc58938198420ebdbf1be3913169a4193
+ source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.7.28-cp39-cp39-manylinux1_x86_64.whl
+ b2sums = 6511e60a98651086826766ae87232f8c168c370f6d8da3759e279dee53ea12a11024e301885ab81b5713a592030a9e2b9fc69cc282535e62c0aed28d09acfd38
pkgname = python-taichi
diff --git a/PKGBUILD b/PKGBUILD
index b5057c5b772a..6d9cf66349e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
+#!/bin/bash
+
# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
-pkgname='python-taichi'
+pkgname=python-taichi
_name=${pkgname#python-}
-_py='cp39'
-pkgver=0.7.26
+_py=cp39
+pkgver=0.7.28
pkgrel=1
-pkgdesc="Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs"
+pkgdesc='Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs'
+url='https://github.com/taichi-dev/taichi'
arch=('x86_64')
-url="https://github.com/taichi-dev/taichi"
license=('MIT')
-depends=('python'
+depends=(
+ 'python'
'python-astor'
'python-numpy'
'pybind11'
@@ -18,7 +21,8 @@ depends=('python'
'ncurses5-compat-libs'
'libx11'
)
-optdepends=('python-autograd'
+optdepends=(
+ 'python-autograd'
'python-sourceinspect'
'python-astpretty'
'python-colorama'
@@ -26,24 +30,23 @@ optdepends=('python-autograd'
'yapf'
'cuda')
makedepends=('python-setuptools')
-
-source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name//-/_}-$pkgver-$_py-${_py}-manylinux1_x86_64.whl")
-
-b2sums=('a0efba9e913013cbae8b0d8e7bac1dfe5a91abfee12be961e69cfabea614e0fbc1b124694264a561d7ecd3863964a42dc58938198420ebdbf1be3913169a4193')
+source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name//-/_}-$pkgver-$_py-$_py-manylinux1_x86_64.whl")
+b2sums=('6511e60a98651086826766ae87232f8c168c370f6d8da3759e279dee53ea12a11024e301885ab81b5713a592030a9e2b9fc69cc282535e62c0aed28d09acfd38')
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-warn-script-location --no-deps ${_name//-/_}-$pkgver-$_py-${_py}-manylinux1_x86_64.whl
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-warn-script-location --no-deps ${_name//-/_}-$pkgver-$_py-$_py-manylinux1_x86_64.whl
- cd $pkgdir/usr/lib/python3.9/site-packages/$_name/
- # remove pyc and compile by my self
- find . -name "*.pyc" | xargs rm -rf
+ cd "$pkgdir/usr/lib/python3.9/site-packages/$_name/" || exit
+ # remove pyc and compile by itself
+ find . -name "*.pyc" -print0 | xargs rm -rf
- # remove prefix
- python -O -m compileall -f "${pkgdir}/usr/lib/python3.9/site-packages/$_name/" -s "${pkgdir}" -p "/"
+ # remove prefix compile pyc again
+ python -O -m compileall -f "${pkgdir}/usr/lib/python3.9/site-packages/$_name/" -s "$pkgdir" -p "/"
# manually rewrite direct_url.json
- cd $pkgdir/usr/lib/python3.9/site-packages/$_name-$pkgver.dist-info/
- echo "{\"archive_info\": {\"hash\": \"b2sums=$b2sums\"}, \"url\": \"$source\"}" >direct_url.json
+ cd "$pkgdir/usr/lib/python3.9/site-packages/$_name-$pkgver.dist-info/" || exit
+
+ echo "{\"archive_info\": {\"hash\": \"b2sums=${b2sums[0]}\"}, \"url\": \"${source[0]}\"}" >direct_url.json
- install -Dm644 "$srcdir/$_name-$pkgver.dist-info/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_name-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}