summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-07-14 09:41:45 +0800
committerPumpkinCheshire2021-07-14 09:41:45 +0800
commitff4b7c174517a88bb8fae0a15a735c1488f9c078 (patch)
tree007e1e36e527ddd584b08a923f2abb8e000e2615
parentb1c811a362a53cae0e9b4a9ed35ce7ee72c32341 (diff)
downloadaur-ff4b7c174517a88bb8fae0a15a735c1488f9c078.tar.gz
bump to 0.7.26
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19db4e674416..643d198a54bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-taichi
pkgdesc = Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs
- pkgver = 0.7.24
+ pkgver = 0.7.26
pkgrel = 1
url = https://github.com/taichi-dev/taichi
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = python-taichi
depends = python-pillow
depends = python-dill
depends = ncurses5-compat-libs
+ depends = libx11
optdepends = python-autograd
optdepends = python-sourceinspect
optdepends = python-astpretty
@@ -20,7 +21,7 @@ pkgbase = python-taichi
optdepends = python-gitpython
optdepends = yapf
optdepends = cuda
- source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.7.24-cp39-cp39-manylinux1_x86_64.whl
- b2sums = 6f0f99ced428b080ab140bcb71d87340c917e30cfb5df916e2b0502850cc29cecdc766e618d01d7e5232995ff147d22c575a8315c7226a86f87ef0e02a7e8654
+ source = https://files.pythonhosted.org/packages/cp39/t/taichi/taichi-0.7.26-cp39-cp39-manylinux1_x86_64.whl
+ b2sums = a0efba9e913013cbae8b0d8e7bac1dfe5a91abfee12be961e69cfabea614e0fbc1b124694264a561d7ecd3863964a42dc58938198420ebdbf1be3913169a4193
pkgname = python-taichi
diff --git a/PKGBUILD b/PKGBUILD
index 30853b9da3c8..b5057c5b772a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='python-taichi'
_name=${pkgname#python-}
_py='cp39'
-pkgver=0.7.24
+pkgver=0.7.26
pkgrel=1
pkgdesc="Productive & portable programming language for high-performance, sparse & differentiable computing on CPUs & GPUs"
arch=('x86_64')
@@ -16,6 +16,7 @@ depends=('python'
'python-pillow'
'python-dill'
'ncurses5-compat-libs'
+ 'libx11'
)
optdepends=('python-autograd'
'python-sourceinspect'
@@ -28,7 +29,7 @@ makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name//-/_}-$pkgver-$_py-${_py}-manylinux1_x86_64.whl")
-b2sums=('6f0f99ced428b080ab140bcb71d87340c917e30cfb5df916e2b0502850cc29cecdc766e618d01d7e5232995ff147d22c575a8315c7226a86f87ef0e02a7e8654')
+b2sums=('a0efba9e913013cbae8b0d8e7bac1dfe5a91abfee12be961e69cfabea614e0fbc1b124694264a561d7ecd3863964a42dc58938198420ebdbf1be3913169a4193')
package() {
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-warn-script-location --no-deps ${_name//-/_}-$pkgver-$_py-${_py}-manylinux1_x86_64.whl