summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2020-06-22 21:55:41 +0800
committerButui Hu2020-06-22 21:55:41 +0800
commitea35275a6690a2488c390554b696883d5f455285 (patch)
tree65f64ee666b95b0850e35e7f7b2dea13afd85445
downloadaur-ea35275a6690a2488c390554b696883d5f455285.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..183b0e0a2bef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-tangled-up-in-unicode
+ pkgdesc = Access to the Unicode Character Database (UCD)
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/dylan-profiler/tangled-up-in-unicode
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = tangled-up-in-unicode-0.0.6.tar.gz::https://github.com/dylan-profiler/tangled-up-in-unicode/archive/v0.0.6.tar.gz
+ sha512sums = 1e6e2251184ab02bf257c988bb499f2de59c451b41b1244454888bdab8d84e4379a07527c10be3421de9588632405da27e81adbbd4cd677ced3e272bf289ddd5
+
+pkgname = python-tangled-up-in-unicode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62a85fdd71e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+pkgname=python-tangled-up-in-unicode
+_pkgname=tangled-up-in-unicode
+pkgver=0.0.6
+pkgrel=1
+pkgdesc='Access to the Unicode Character Database (UCD)'
+arch=('any')
+url='https://github.com/dylan-profiler/tangled-up-in-unicode'
+license=('BSD')
+depends=(
+ python
+)
+makedepends=(python-setuptools)
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dylan-profiler/tangled-up-in-unicode/archive/v${pkgver}.tar.gz")
+sha512sums=('1e6e2251184ab02bf257c988bb499f2de59c451b41b1244454888bdab8d84e4379a07527c10be3421de9588632405da27e81adbbd4cd677ced3e272bf289ddd5')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: