summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2021-10-16 16:35:19 +1100
committerMatthew Gamble2021-10-16 16:35:19 +1100
commit61a459f9d01bde375157da17ef802b6f00c5623f (patch)
treef5615bd675cc3334bd1b50c26609d01752678508
parent44d3b3463fadc324381976760b03bfa099c333b7 (diff)
downloadaur-61a459f9d01bde375157da17ef802b6f00c5623f.tar.gz
Fix build again
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3366d95f3902..b18f8084860f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-tatsu
pkgdesc = TatSu takes a grammar in a variation of EBNF as input, and outputs a memoizing PEG/Packrat parser in Python.
pkgver = 5.6.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/neogeny/TatSu
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index c927f3917707..35cf4753ea83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-tatsu
pkgver=5.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="TatSu takes a grammar in a variation of EBNF as input, and outputs a memoizing PEG/Packrat parser in Python."
arch=("any")
url="https://github.com/neogeny/TatSu"
@@ -26,7 +26,12 @@ build() {
package() {
cd "TatSu-${pkgver}"
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0], end='')")
+
PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ rm -r "${pkgdir}${_site_packages}/test"
+ chmod -R o+r "${pkgdir}${_site_packages}/"*.egg-info
+
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-tatsu/LICENSE.txt"
install -Dm644 README.rst "${pkgdir}/usr/share/doc/python-tatsu/README.rst"
install -Dm644 CHANGELOG.rst "${pkgdir}/usr/share/doc/python-tatsu/CHANGELOG.rst"