summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Owens2020-04-29 09:34:22 -0500
committerNathan Owens2020-04-29 09:34:22 -0500
commitab8dc9f114b80b41ef0079d76a6488a5041d0fc9 (patch)
treed3bba06af14312291c0e9541b26bc65c4ae2e333
parent99fa2127ff4465df221c05d5dc0f4e2b35b99349 (diff)
downloadaur-ab8dc9f114b80b41ef0079d76a6488a5041d0fc9.tar.gz
Update to 5.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
2 files changed, 16 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57c773d4458a..2f479798388b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = python-tatsu
pkgdesc = A tool that takes grammars in a variation of EBNF as input, and outputs memoizing (Packrat) PEG parsers in Python
- pkgver = 4.4.0
+ pkgver = 5.0.0
pkgrel = 1
url = https://github.com/neogeny/TatSu
arch = any
- license = custom: BSD
+ license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = python-tatsu-4.4.0.tar.gz::https://github.com/neogeny/TatSu/archive/v4.4.0.tar.gz
- sha256sums = db392dffa3a847f748490e7dc5e4a37c6004aa5b4712a8b122ad3fdf43676a3e
-
-pkgname = python-tatsu
- pkgdesc = A tool that takes grammars in a variation of EBNF as input, and outputs memoizing (Packrat) PEG parsers in Python (python3 version)
+ makedepends = git
depends = python
+ source = git+https://github.com/neogeny/TatSu#tag=v5.0.0
+ sha256sums = SKIP
-pkgname = python2-tatsu
- pkgdesc = A tool that takes grammars in a variation of EBNF as input, and outputs memoizing (Packrat) PEG parsers in Python (python2 version)
- depends = python2
+pkgname = python-tatsu
diff --git a/PKGBUILD b/PKGBUILD
index 00c91bc4b216..77df8e1e04e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,21 @@
-# Maintainer:
# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-pkgbase=python-tatsu
-pkgname=(python-tatsu python2-tatsu)
-pkgver=4.4.0
+pkgname=python-tatsu
+pkgver=5.0.0
pkgrel=1
pkgdesc="A tool that takes grammars in a variation of EBNF as input, and outputs memoizing (Packrat) PEG parsers in Python"
arch=('any')
url="https://github.com/neogeny/TatSu"
-license=('custom: BSD')
+license=('BSD')
+depends=('python')
makedepends=('python-setuptools'
- 'python2-setuptools')
-source=($pkgname-$pkgver.tar.gz::"https://github.com/neogeny/TatSu/archive/v$pkgver.tar.gz")
-sha256sums=('db392dffa3a847f748490e7dc5e4a37c6004aa5b4712a8b122ad3fdf43676a3e')
+ 'git')
+source=("git+https://github.com/neogeny/TatSu#tag=v$pkgver")
+sha256sums=('SKIP')
-prepare() {
- # copy folder, so we can cleanly build for both python versions
- cp -rup TatSu-$pkgver TatSu-$pkgver-py2
-}
-
-# package for python 3
-package_python-tatsu() {
- depends=('python')
- pkgdesc+=" (python3 version)"
-
- cd TatSu-$pkgver
+package() {
+ cd "$srcdir/TatSu"
python setup.py install --root="$pkgdir/" --optimize=1
@@ -33,22 +24,3 @@ package_python-tatsu() {
install -Dm644 README.rst "$pkgdir"/usr/share/doc/$pkgname/README.rst
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
}
-
-# package for python 2
-package_python2-tatsu() {
- depends=('python2')
- pkgdesc+=" (python2 version)"
-
- cd TatSu-$pkgver-py2
-
- python2 setup.py install --root="$pkgdir/" --optimize=1
-
- rm -rf "$pkgdir"/usr/lib/python2.*/site-packages/test
-
- install -Dm644 README.rst "$pkgdir"/usr/share/doc/$pkgname/README.rst
- install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
-
- # non-conflicting executable names
- mv "$pkgdir"/usr/bin/tatsu "$pkgdir"/usr/bin/tatsu-py2
- mv "$pkgdir"/usr/bin/g2e "$pkgdir"/usr/bin/g2e-py2
-}