summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2023-12-02 17:07:56 +0100
committerSimon Brulhart2023-12-02 17:09:10 +0100
commit822df415055c78796e37f7217e44cf4aed194c28 (patch)
treee18c30bd7e02df531b2dbd09c8125ac8fbf602c3
parent214d20004b6805444b96261543cb862cf37bb2c6 (diff)
downloadaur-822df415055c78796e37f7217e44cf4aed194c28.tar.gz
Update to v6.3.1
Adapt PKGBUILD for migration to flit build system.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fedfcf6c670a..55c79e7e727b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = python-taxi
pkgdesc = Timesheeting tool that focuses on simplicity
- pkgver = 6.2.0
+ pkgver = 6.3.1
pkgrel = 1
url = https://github.com/sephii/taxi
arch = any
license = custom
makedepends = python
- makedepends = python-setuptools
+ makedepends = python-flit
+ makedepends = python-installer
depends = python-appdirs
depends = python-click
- depends = python-six
optdepends = python-taxi-zebra: Zebra backend for Taxi
- source = python-taxi-6.2.0.tar.gz::https://github.com/sephii/taxi/archive/6.2.0.tar.gz
+ source = python-taxi-6.3.1.tar.gz::https://github.com/sephii/taxi/archive/6.3.1.tar.gz
source = taxi-complete.bash
source = taxi-complete.zsh
- sha512sums = a1599e4830a5575b5316ffdf277dd7311b066e67865c0af35bdc72dccc16cc05335759ef98591872160a0adbb1a3f8cab854af6e7a7cc41e61ab2748080fa4ea
+ sha512sums = fb1ab86d06b3272f9cdec3f22298b0b5353e6efd489f6941da88b5f28c8584f6b91c9280d2ab6fdda0a063fb5e1f444b33f0947830ebd8fbcb879ca143316254
sha512sums = 646ac547f52fb9a1c8498a9d1d431a3c19b41faacd86b7344ffb8c2334e6b01b765945882e5180c7f658b8c3f6a7887a690171b624326b5b3fa3ecda59344ccc
sha512sums = d02c0e3489dba8841eff335571088b739911d4c541623971cfef9b1628ea6960ad748e1e6c4cc1dfdd20dc88fc289f8078dbb51fa0402eed4868c45e87f4106a
diff --git a/PKGBUILD b/PKGBUILD
index 8bdddbe3379a..01701bc3161f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
# Maintainer: Simon Brulhart <simon@brulhart.me>
pkgname=python-taxi
-pkgver=6.2.0
+pkgver=6.3.1
pkgrel=1
pkgdesc="Timesheeting tool that focuses on simplicity"
arch=('any')
license=('custom')
url="https://github.com/sephii/taxi"
-depends=('python-appdirs' 'python-click' 'python-six')
-makedepends=('python' 'python-setuptools')
+depends=('python-appdirs' 'python-click')
+makedepends=('python' 'python-flit' 'python-installer')
optdepends=("python-taxi-zebra: Zebra backend for Taxi")
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/sephii/taxi/archive/$pkgver.tar.gz"
taxi-complete.bash
taxi-complete.zsh
)
-sha512sums=('a1599e4830a5575b5316ffdf277dd7311b066e67865c0af35bdc72dccc16cc05335759ef98591872160a0adbb1a3f8cab854af6e7a7cc41e61ab2748080fa4ea'
+sha512sums=('fb1ab86d06b3272f9cdec3f22298b0b5353e6efd489f6941da88b5f28c8584f6b91c9280d2ab6fdda0a063fb5e1f444b33f0947830ebd8fbcb879ca143316254'
'646ac547f52fb9a1c8498a9d1d431a3c19b41faacd86b7344ffb8c2334e6b01b765945882e5180c7f658b8c3f6a7887a690171b624326b5b3fa3ecda59344ccc'
'd02c0e3489dba8841eff335571088b739911d4c541623971cfef9b1628ea6960ad748e1e6c4cc1dfdd20dc88fc289f8078dbb51fa0402eed4868c45e87f4106a')
build() {
cd "$srcdir/taxi-$pkgver"
- python setup.py build
+ flit build --no-use-vcs
}
package() {
cd "$srcdir/taxi-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
cd "$srcdir"